summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-28 06:58:25 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-28 07:43:44 +0100
commita2515295cc2fc1ba974c33e65198689b136a5d8d (patch)
tree955a93e0ca2149e542e5c7840776ea5b0dba3a7e /dev-python
parentdev-python/sigstore: Remove old (diff)
downloadgentoo-a2515295cc2fc1ba974c33e65198689b136a5d8d.tar.gz
gentoo-a2515295cc2fc1ba974c33e65198689b136a5d8d.tar.bz2
gentoo-a2515295cc2fc1ba974c33e65198689b136a5d8d.zip
dev-python/fastjsonschema: Bump to 2.21.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fastjsonschema/Manifest1
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.21.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/Manifest b/dev-python/fastjsonschema/Manifest
index cb5819766185..9f022e615d61 100644
--- a/dev-python/fastjsonschema/Manifest
+++ b/dev-python/fastjsonschema/Manifest
@@ -1 +1,2 @@
DIST fastjsonschema-2.20.0.tar.gz 373056 BLAKE2B 99e80a6aa05aef421c5d95149f5f40f0a732bd686888f32067295c19d9c1d7569bf628d06b59bbeb68ea302e06de700b05c27e7a44e018b213e0c1a7f4dc1304 SHA512 7881937a02c7487d1dfd7499dbe85e8f8e359b9686673f32491d93cef1d7a949df5309b0d4a5cc525a7d9c8269568bc34e9d072ec1a49e44d5becbf8718b250d
+DIST fastjsonschema-2.21.0.tar.gz 373839 BLAKE2B 24e559d796ab38051921e797d7a6d72cea8fbaff47ff637ea481ded46aedd2ed2c5f4dc67c46b93f1100afecd8db6a80964a59a4c1f1b24ffad8f0058549cbbb SHA512 b68081f969b9f4bfabe62040e559d7c0e58a1e81f31c33d09d5c2f0eb04d8386e9cac6590cb509ac93ecaa465c399b095d3b362ecbb81bb3ea09ba27f5d8ceb5
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.21.0.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.21.0.ebuild
new file mode 100644
index 000000000000..0927d4ed5c46
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.21.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="
+ https://github.com/horejsek/python-fastjsonschema/
+ https://pypi.org/project/fastjsonschema/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/benchmarks
+)