summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-13 23:36:59 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-14 00:13:55 +0100
commit5e90bce86360764e981b6cba9d486908f67a7d22 (patch)
tree332140b477ab6c90714b83f60ac6cd76cb2589c2 /dev-python
parentdev-python/prettytable: Bump to 3.1.0 (diff)
downloadgentoo-5e90bce86360764e981b6cba9d486908f67a7d22.tar.gz
gentoo-5e90bce86360764e981b6cba9d486908f67a7d22.tar.bz2
gentoo-5e90bce86360764e981b6cba9d486908f67a7d22.zip
dev-python/puremagic: Bump to 1.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/puremagic/Manifest1
-rw-r--r--dev-python/puremagic/puremagic-1.12.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/puremagic/Manifest b/dev-python/puremagic/Manifest
index 2e3d2c4c5ae2..8bc3572c0e31 100644
--- a/dev-python/puremagic/Manifest
+++ b/dev-python/puremagic/Manifest
@@ -1 +1,2 @@
DIST puremagic-1.11.tar.gz 295026 BLAKE2B 4d210807d9f5eb0c2eb88b0c18aa5cdf56170b347de4f95b92c08492d5f038759b39c1aa2d6ed4bc91e96e036e6f4d0891449af8aee3beac65c4d692fa295ec0 SHA512 4d4c9a93cd56a02aefb7090c92b41048f33923bef14022158f39c39ac93326b7180b8cc97495ad5ed3eec7d9f1379a5508829ee779aaba9b8aa8f975e787b1f5
+DIST puremagic-1.12.tar.gz 296831 BLAKE2B cd9979fba1016b1c4cbdd9ef1402d11dbe2faf37767e3232cf400b798cce328d90d224765cc2bf39fd0988abdfe39d1527dd7aa6e31b4737d00c1578f1cc3101 SHA512 b50e22b7597f206e8d6dbc0e2c120af21a7246568f059c6145e45471eedf04c797a9f00864468d5e05c9536f49f7fc6c7b30a83e67bf248e10ebaf8300726fde
diff --git a/dev-python/puremagic/puremagic-1.12.ebuild b/dev-python/puremagic/puremagic-1.12.ebuild
new file mode 100644
index 000000000000..55ab3d289e19
--- /dev/null
+++ b/dev-python/puremagic/puremagic-1.12.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python implementation of magic file detection"
+HOMEPAGE="https://github.com/cdgriffith/puremagic"
+SRC_URI="https://github.com/cdgriffith/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CHANGELOG.md README.rst )
+
+distutils_enable_tests pytest