summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-27 06:06:29 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-27 06:47:12 +0100
commit4b164c14236e95161041476317ee786f78d7bed5 (patch)
tree43f461b03da68f400d576c537ab52c9124c5c64a /dev-python
parentdev-python/libtmux: Remove old (diff)
downloadgentoo-4b164c14236e95161041476317ee786f78d7bed5.tar.gz
gentoo-4b164c14236e95161041476317ee786f78d7bed5.tar.bz2
gentoo-4b164c14236e95161041476317ee786f78d7bed5.zip
dev-python/libtmux: Bump to 0.38.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/libtmux/Manifest1
-rw-r--r--dev-python/libtmux/libtmux-0.38.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/libtmux/Manifest b/dev-python/libtmux/Manifest
index 76685a5d4dab..bedac197f50e 100644
--- a/dev-python/libtmux/Manifest
+++ b/dev-python/libtmux/Manifest
@@ -1,2 +1,3 @@
DIST libtmux-0.36.0.gh.tar.gz 282828 BLAKE2B 247f98ae47093090187f2d52792f850f7476427b368f46970ef3fe9bd6449c03ac23101c8c7af711167bbd92e9e2cff3754474375dabd48157154ed89975a71a SHA512 2fa16a55d4b46461d1266179cfa6cf8d710fdbe435369ff195a683a96243b2b7cd2fbeb47b88e3a660c23d3ca57e1c2722bc12492c52ee0961a1c5cc99ceb093
DIST libtmux-0.37.0.gh.tar.gz 283496 BLAKE2B ef8c9c05cc20f549fc13ffb05276e1ba5b24c366c9cf44eb5ffe609cfe0e603ab7a90747b5df03afa62a6a9d8c81904e7fa7e4598092d3b11c0e9295e413d88d SHA512 8876ad13613d367d6a6ea5945b5a0a495460b5ad68a14d89d20a41f0e5b421e0007041e4e8356e88a8eefb2b2422be306aebd2452e3be556f1cc4fd232327499
+DIST libtmux-0.38.1.gh.tar.gz 304345 BLAKE2B f4380c813b57045cc8dcf4ad18124bcd2aa304495ea0cfbfcfa2e7f9f8140fa2acb4545b4c9b61a13f08a12e57c0e7f7de20f673f9054429eca22968cf51f651 SHA512 ca88e67222e7abb54afc88c11dcded19ee870d8d4bc3e26de61ca24ccb6294f3f8be0ec652c0d8fd4137d57a56338fedd4930e6bfb1693d45fd41a63f352ee9b
diff --git a/dev-python/libtmux/libtmux-0.38.1.ebuild b/dev-python/libtmux/libtmux-0.38.1.ebuild
new file mode 100644
index 000000000000..2a7ca9255d71
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.38.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Typed library that provides an ORM wrapper for tmux, a terminal multiplexer"
+HOMEPAGE="
+ https://libtmux.git-pull.com/
+ https://github.com/tmux-python/libtmux/
+ https://pypi.org/project/libtmux/
+"
+SRC_URI="
+ https://github.com/tmux-python/libtmux/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+
+ # increase timeouts for tests
+ sed -e 's/0.01/0.1/' -i tests/test_test.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # tests/test_window.py::test_fresh_window_data fails if TMUX_PANE is set
+ # https://bugs.gentoo.org/927158
+ local -x TMUX_PANE=
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=libtmux.pytest_plugin
+
+ local EPYTEST_DESELECT=(
+ # flaky tests
+ tests/legacy_api/test_test.py::test_function_times_out
+ tests/legacy_api/test_test.py::test_function_times_out_no_raise
+ tests/legacy_api/test_test.py::test_function_times_out_no_raise_assert
+ )
+ epytest -o addopts= -p pytest_mock -p rerunfailures tests
+}