summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/dogpile-cache
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/dogpile-cache')
-rw-r--r--dev-python/dogpile-cache/Manifest3
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-0.5.1.ebuild30
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-0.5.2.ebuild37
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-0.5.4.ebuild38
-rw-r--r--dev-python/dogpile-cache/metadata.xml18
5 files changed, 126 insertions, 0 deletions
diff --git a/dev-python/dogpile-cache/Manifest b/dev-python/dogpile-cache/Manifest
new file mode 100644
index 000000000000..246402e2b3cd
--- /dev/null
+++ b/dev-python/dogpile-cache/Manifest
@@ -0,0 +1,3 @@
+DIST dogpile.cache-0.5.1.tar.gz 169450 SHA256 1f3165222bc23418cb9d3f1a2c9d554a091f412e5bc871ea0c48a19b576d06c0 SHA512 e9b9b8b7caf269cfecc8d333bd04714d908860e1e54720ce3329fae7be14995f8de6f1225e0cf6a782d5ef53ddd3482acc36a3440eb772e03f3d5029faeecc5c WHIRLPOOL ba14fc61604c78af038b6520079bbca1a46a889abebf69305f5722142cd47a45da966d8db64ec24cc7148363a22b109d89e4200087cc235a0721aea94f5c6a2c
+DIST dogpile.cache-0.5.2.tar.gz 173765 SHA256 acdcb69e7eb8421678172fe8709d6d92bf7249022a70e4d7c84316d4e2d1d1b5 SHA512 dcce0e06de4d053e16020ca32f210c79a7eab21b7d09a8041e655940f03e32c91919a26d75114fffa087bc8a33052d5b1b04aeaea92d663ba4237f2990de2f05 WHIRLPOOL 8cec6f397487dbd2d61e1ed0f9b96f08d0f560af2f13b92b819d5fb402616d59a8c1a50aab518c07413af40b9405214ff4b66448912e33839a7a8b9920541b76
+DIST dogpile.cache-0.5.4.tar.gz 185676 SHA256 9eab7a5dc05ad1b6573144c4a2717226b5c38811f9ec29b514e774535a91ea24 SHA512 ae73b8c82745cbde7b46f532e127c044a01e7b85d2e91b5f0a16da51fb9d70d48e2de55278db68f892a9b604e4f32e19a4a73c11393e04b599c8892280f9b5fe WHIRLPOOL 97b6dd6374940f081d60a7eba43844f17f39dbfa6df14ef18e9e8241b844f467126f4ffca3dd284408855d46c7f2299bb24bc9f2715271e2303e440a3b912f95
diff --git a/dev-python/dogpile-cache/dogpile-cache-0.5.1.ebuild b/dev-python/dogpile-cache/dogpile-cache-0.5.1.ebuild
new file mode 100644
index 000000000000..b45f52510615
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-0.5.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="API built on a lock allowing access to expiring values while a single thread generates a new value."
+HOMEPAGE="https://bitbucket.org/zzzeek/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-core-0.4.1[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+# This time half the doc files are missing; Do you want them?
+
+python_test() {
+ nosetests || die "test failed under ${EPYTHON}"
+}
diff --git a/dev-python/dogpile-cache/dogpile-cache-0.5.2.ebuild b/dev-python/dogpile-cache/dogpile-cache-0.5.2.ebuild
new file mode 100644
index 000000000000..280e6fe8bb4f
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-0.5.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="API built on a lock allowing access to expiring values while a single thread generates a new value."
+HOMEPAGE="https://bitbucket.org/zzzeek/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/dogpile-core-0.4.1[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-core-0.4.1[${PYTHON_USEDEP}] )"
+
+# for testsuite
+DISTUTILS_NO_PARALLEL_BUILD=1
+# This time half the doc files are missing; Do you want them? toss a coin
+
+python_test() {
+ # crikey. testsuite written for py3, 5 tests fail under py2.7
+ if [[ "${EPYTHON}" != "python2.7" ]]; then
+ nosetests || die "test failed under ${EPYTHON}"
+ else
+ einfo "testsuite restricted for python2.7"
+ fi
+}
diff --git a/dev-python/dogpile-cache/dogpile-cache-0.5.4.ebuild b/dev-python/dogpile-cache/dogpile-cache-0.5.4.ebuild
new file mode 100644
index 000000000000..ab2ca0440e34
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-0.5.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="API built on a lock allowing access to expiring values while a single thread generates a new value."
+HOMEPAGE="https://bitbucket.org/zzzeek/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/dogpile-core-0.4.1[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-core-0.4.1[${PYTHON_USEDEP}] )"
+
+# for testsuite
+DISTUTILS_NO_PARALLEL_BUILD=1
+# This time half the doc files are missing; Do you want them? toss a coin
+
+python_test() {
+ # crikey. testsuite written for py3, 5 tests fail under py2.7
+ if [[ "${EPYTHON}" != "python2.7" ]]; then
+ nosetests || die "test failed under ${EPYTHON}"
+ else
+ einfo "testsuite restricted for python2.7"
+ fi
+}
diff --git a/dev-python/dogpile-cache/metadata.xml b/dev-python/dogpile-cache/metadata.xml
new file mode 100644
index 000000000000..108d29fd0ac5
--- /dev/null
+++ b/dev-python/dogpile-cache/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A caching API built around the concept of a "dogpile lock", which allows
+ continued access to an expiring data value while
+ a single thread generates a new value.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">dogpile.cache</remote-id>
+ <remote-id type="bitbucket">zzzeek/dogpile.cache</remote-id>
+ </upstream>
+</pkgmetadata>