summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-06-11 15:01:17 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-06-11 15:25:53 -0400
commit63648ff64cd10e2c13a74d163e34842f06d1a368 (patch)
treefa1c5a57ac9e13e6ee20f24c5c4f91661f84652c /dev-php
parentdev-php/PEAR-Console_CommandLine: test deps should be BDEPEND in EAPI=8 (diff)
downloadgentoo-63648ff64cd10e2c13a74d163e34842f06d1a368.tar.gz
gentoo-63648ff64cd10e2c13a74d163e34842f06d1a368.tar.bz2
gentoo-63648ff64cd10e2c13a74d163e34842f06d1a368.zip
dev-php/PEAR-Mail_Mime: add 1.10.12
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Mail_Mime/Manifest1
-rw-r--r--dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.12.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/PEAR-Mail_Mime/Manifest b/dev-php/PEAR-Mail_Mime/Manifest
index fab2f696e5db..9f08d2db4f17 100644
--- a/dev-php/PEAR-Mail_Mime/Manifest
+++ b/dev-php/PEAR-Mail_Mime/Manifest
@@ -1 +1,2 @@
DIST Mail_Mime-1.10.11.tgz 40930 BLAKE2B e02f5f8fc43949a32edf4a8fc835e4a6b4f44b509f3066b35ca0822a4cc723eb5fba860161a88d10d788811e5ef34d72e845fbf9b2768a83d87bc95445e8a967 SHA512 405873f92542f6f6d4433959ed3c741d64afe70852ddc9582d995485f327f662bccc82af0dfef3ccca61ec6497d67ea8f9d04d95f25443c57e3a319f96f7ac30
+DIST Mail_Mime-1.10.12.tgz 41003 BLAKE2B c5b9ebe167d8698794a32a8995f82ab535e99666056aa5240f3628b5311966178b70bd2587e1bd5fbcb68a7841b4653617a2d0a25d5f62d4f23b24871dff2a70 SHA512 ce25f788ee9b8f0ce3879a5697f6b7e2e117bf30c6aaf8cf4cfa05723021c8a85152f7142dd5b30c8cf1658d1bc3d6284ea5ce1984b8fae27164661ad6b47b96
diff --git a/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.12.ebuild b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.12.ebuild
new file mode 100644
index 000000000000..34934980a7d1
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.12.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit php-pear-r2
+
+DESCRIPTION="Create and manipulate mime messages with PHP"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-php/PEAR-PEAR )"
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}