summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-07-18 18:49:09 -0400
committerMatt Turner <mattst88@gentoo.org>2023-07-20 15:12:17 -0400
commitefde0a27b9793d3a492f2b2f19d92d56fd8a9ddb (patch)
tree991fa9d7f7b1c3a634fe5a11aa6a3a35ecb59264 /dev-libs
parentvirtual/libudev: Version bump to 251 (diff)
downloadgentoo-efde0a27b9793d3a492f2b2f19d92d56fd8a9ddb.tar.gz
gentoo-efde0a27b9793d3a492f2b2f19d92d56fd8a9ddb.tar.bz2
gentoo-efde0a27b9793d3a492f2b2f19d92d56fd8a9ddb.zip
dev-libs/libgudev: Version bump to 238
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgudev/Manifest1
-rw-r--r--dev-libs/libgudev/libgudev-238.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/libgudev/Manifest b/dev-libs/libgudev/Manifest
index d8d7cbc1d4e6..d6f2213c58f4 100644
--- a/dev-libs/libgudev/Manifest
+++ b/dev-libs/libgudev/Manifest
@@ -1 +1,2 @@
DIST libgudev-237.tar.xz 29060 BLAKE2B 5d39d4d26d8c8b3fa877319c294036294dbda96b340d2d04d7a35449d91b58de876b96b5e3d9423cdf3e1d3e2a94f5a861b1ac1e74a610637e0fc66248c68309 SHA512 2d68981e3ba5c58ee080b6ed5cd5152c1c352b2bdb3ecb5eaf2b91f6800d3369121222a7fe4f82630aabd164069ee7276c52082b2fc2ff5f318481b85b25abc6
+DIST libgudev-238.tar.xz 30548 BLAKE2B 386491e78c82081e89dad897d16ea6733430a67db3f75f2d9fdee5474b074ad6fede9f08e429f4eb6feaa9bbbb982d9d039db738aac5b5ce0ffac2d3a19430d4 SHA512 684061b4fc64a6ea3dd1ac34835279330c7eb2728fad6e3a9d34c0d501be3103d0f96c6d6866c8e257a0027e4f78a6314cb8ba81cda5ddf42ee9ea1a576ec5dc
diff --git a/dev-libs/libgudev/libgudev-238.ebuild b/dev-libs/libgudev/libgudev-238.ebuild
new file mode 100644
index 000000000000..a71d45bcd0ac
--- /dev/null
+++ b/dev-libs/libgudev/libgudev-238.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2015-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson-multilib
+
+DESCRIPTION="GObject bindings for libudev"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgudev"
+SRC_URI="https://download.gnome.org/sources/libgudev/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.38.0:2[${MULTILIB_USEDEP}]
+ >=virtual/libudev-251:=[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-util/umockdev[${MULTILIB_USEDEP}] )
+"
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_feature introspection)
+ -Dgtk_doc=false
+ $(meson_feature test tests)
+ -Dvapi=disabled
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # libsandbox interferes somehow.
+ # There are no access violations, but tests fail.
+ # https://bugs.gentoo.org/805449
+ local -x SANDBOX_ON=0
+ meson-multilib_src_test
+}