summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-10-31 14:38:45 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-10-31 14:38:45 +0200
commit8cb190827ef65b5711693a08333f5cf3729a0826 (patch)
tree475e335f748de7ed87de9491b3aa73fbd09f45e8 /dev-libs/rapidxml
parentpackage.mask: Last rite sys-apps/frandom (diff)
downloadgentoo-8cb190827ef65b5711693a08333f5cf3729a0826.tar.gz
gentoo-8cb190827ef65b5711693a08333f5cf3729a0826.tar.bz2
gentoo-8cb190827ef65b5711693a08333f5cf3729a0826.zip
dev-libs/rapidxml: treeclean
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/rapidxml')
-rw-r--r--dev-libs/rapidxml/Manifest1
-rw-r--r--dev-libs/rapidxml/files/rapidxml-1.13-clang.patch23
-rw-r--r--dev-libs/rapidxml/files/rapidxml-1.13-iterators.patch48
-rw-r--r--dev-libs/rapidxml/metadata.xml11
-rw-r--r--dev-libs/rapidxml/rapidxml-1.13-r1.ebuild26
5 files changed, 0 insertions, 109 deletions
diff --git a/dev-libs/rapidxml/Manifest b/dev-libs/rapidxml/Manifest
deleted file mode 100644
index 845a370f2336..000000000000
--- a/dev-libs/rapidxml/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST rapidxml-1.13.zip 44163 BLAKE2B 9db90dfca1943c47e95541a323e1210368447c054cf072d6768031488070e375fe2aa78a4e41f61f252d4c487e94cf1e24e4d3756e3f8774b0c2c52ef86959e7 SHA512 6c10583e6631ccdb0217d0a5381172cb4c1046226de6ef1acf398d85e81d145228e14c3016aefcd7b70a1db8631505b048d8b4f5d4b0dbf1811d2482eefdd265
diff --git a/dev-libs/rapidxml/files/rapidxml-1.13-clang.patch b/dev-libs/rapidxml/files/rapidxml-1.13-clang.patch
deleted file mode 100644
index 7609984f5a28..000000000000
--- a/dev-libs/rapidxml/files/rapidxml-1.13-clang.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/rapidxml_print.hpp
-+++ b/rapidxml_print.hpp
-@@ -102,6 +102,20 @@
- ///////////////////////////////////////////////////////////////////////////
- // Internal printing operations
-
-+ // =====================================
-+ // fix for clang for this bug in gcc and others: https://sourceforge.net/p/rapidxml/bugs/16/
-+
-+ template<class OutIt, class Ch> inline OutIt print_children(OutIt out, const xml_node<Ch> *node, int flags, int indent);
-+ template<class OutIt, class Ch> inline OutIt print_element_node(OutIt out, const xml_node<Ch> *node, int flags, int indent);
-+ template<class OutIt, class Ch> inline OutIt print_data_node(OutIt out, const xml_node<Ch> *node, int flags, int indent);
-+ template<class OutIt, class Ch> inline OutIt print_cdata_node(OutIt out, const xml_node<Ch> *node, int flags, int indent);
-+ template<class OutIt, class Ch> inline OutIt print_declaration_node(OutIt out, const xml_node<Ch> *node, int flags, int indent);
-+ template<class OutIt, class Ch> inline OutIt print_comment_node(OutIt out, const xml_node<Ch> *node, int flags, int indent);
-+ template<class OutIt, class Ch> inline OutIt print_doctype_node(OutIt out, const xml_node<Ch> *node, int flags, int indent);
-+ template<class OutIt, class Ch> inline OutIt print_pi_node(OutIt out, const xml_node<Ch> *node, int flags, int indent);
-+
-+ // =====================================
-+
- // Print node
- template<class OutIt, class Ch>
- inline OutIt print_node(OutIt out, const xml_node<Ch> *node, int flags, int indent)
diff --git a/dev-libs/rapidxml/files/rapidxml-1.13-iterators.patch b/dev-libs/rapidxml/files/rapidxml-1.13-iterators.patch
deleted file mode 100644
index 068545241388..000000000000
--- a/dev-libs/rapidxml/files/rapidxml-1.13-iterators.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-https://sources.debian.org/data/main/r/rapidxml/1.13-3/debian/patches/fix-iterators.patch
-https://bugs.gentoo.org/791328
---- a/rapidxml_iterators.hpp
-+++ b/rapidxml_iterators.hpp
-@@ -18,9 +18,9 @@
-
- public:
-
-- typedef typename xml_node<Ch> value_type;
-- typedef typename xml_node<Ch> &reference;
-- typedef typename xml_node<Ch> *pointer;
-+ typedef typename rapidxml::xml_node<Ch> value_type;
-+ typedef typename rapidxml::xml_node<Ch> &reference;
-+ typedef typename rapidxml::xml_node<Ch> *pointer;
- typedef std::ptrdiff_t difference_type;
- typedef std::bidirectional_iterator_tag iterator_category;
-
-@@ -56,7 +56,7 @@
- node_iterator operator++(int)
- {
- node_iterator tmp = *this;
-- ++this;
-+ ++(*this);
- return tmp;
- }
-
-@@ -70,7 +70,7 @@
- node_iterator operator--(int)
- {
- node_iterator tmp = *this;
-- ++this;
-+ ++(*this);
- return tmp;
- }
-
-@@ -97,9 +97,9 @@
-
- public:
-
-- typedef typename xml_attribute<Ch> value_type;
-- typedef typename xml_attribute<Ch> &reference;
-- typedef typename xml_attribute<Ch> *pointer;
-+ typedef typename rapidxml::xml_attribute<Ch> value_type;
-+ typedef typename rapidxml::xml_attribute<Ch> &reference;
-+ typedef typename rapidxml::xml_attribute<Ch> *pointer;
- typedef std::ptrdiff_t difference_type;
- typedef std::bidirectional_iterator_tag iterator_category;
-
diff --git a/dev-libs/rapidxml/metadata.xml b/dev-libs/rapidxml/metadata.xml
deleted file mode 100644
index cb1847380d2b..000000000000
--- a/dev-libs/rapidxml/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">rapidxml</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-libs/rapidxml/rapidxml-1.13-r1.ebuild b/dev-libs/rapidxml/rapidxml-1.13-r1.ebuild
deleted file mode 100644
index d072ba673bc9..000000000000
--- a/dev-libs/rapidxml/rapidxml-1.13-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Fast XML parser"
-HOMEPAGE="http://rapidxml.sourceforge.net/"
-SRC_URI="mirror://sourceforge/rapidxml/rapidxml-${PV}.zip"
-
-LICENSE="Boost-1.0 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="app-arch/unzip"
-
-PATCHES=(
- "${FILESDIR}"/${P}-iterators.patch
- "${FILESDIR}"/${P}-clang.patch
-)
-
-src_install() {
- insinto /usr/include/rapidxml
- doins *.hpp
- docinto html
- dodoc manual.html
-}