summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-09-14 07:39:00 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-19 22:10:16 +0300
commit01926892b5cb139d71f308fa90587ed489a591ea (patch)
tree9d9f0b0fa8218daab3e56b45dca1bc43930fea3e /dev-db/sqlmap
parentdev-util/bpftrace: drop 0.17.1 (diff)
downloadgentoo-01926892b5cb139d71f308fa90587ed489a591ea.tar.gz
gentoo-01926892b5cb139d71f308fa90587ed489a591ea.tar.bz2
gentoo-01926892b5cb139d71f308fa90587ed489a591ea.zip
dev-db/sqlmap: add 1.7.9
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-db/sqlmap')
-rw-r--r--dev-db/sqlmap/Manifest1
-rw-r--r--dev-db/sqlmap/sqlmap-1.7.9.ebuild60
-rw-r--r--dev-db/sqlmap/sqlmap-9999.ebuild2
3 files changed, 62 insertions, 1 deletions
diff --git a/dev-db/sqlmap/Manifest b/dev-db/sqlmap/Manifest
index 37b4c82dae7a..dda92b539642 100644
--- a/dev-db/sqlmap/Manifest
+++ b/dev-db/sqlmap/Manifest
@@ -1,2 +1,3 @@
DIST sqlmap-1.7.6.gh.tar.gz 7214225 BLAKE2B ab95b3ad10217b94039b6709383873eb93a4992415ab6920ceebfea88ed267ae5a56c08721798663239aa9f226ff40a26d56053c0d04140334bffa1b391c00be SHA512 0d0fa7b1c03db063785accc513e2590ce46e194947cd91325cf10195a4e8c78bb1cada56673032a30a728368ea022dce44e4367d232d912f58f1e16cac62f38b
DIST sqlmap-1.7.8.gh.tar.gz 7214346 BLAKE2B b28da71baa69f09ce8554c96ffedd06c4e41be785956fc895e2cd41d5cfed19af9c294bed8e6dc82e2e6c64704f6be578df3258af1ddad559f99b4b5e9f29c1e SHA512 9d22cd85682de2f111dd33aa7eed6c98e59f2067464f59074c571200e7bb2cc15477560a3c7c81e198f3fd006bde9a9289679c0cec08ffcf0e157d6d1fae4f51
+DIST sqlmap-1.7.9.gh.tar.gz 7214293 BLAKE2B 45ec0a5e0bf2d2f53a9232ca80f592a2a62b195e3dcd6913fdd343afcc097345cd160d7c39571a7abfe25f3772bbfdb1b4e915e6c0b3f599f86ad2eb201f1ab0 SHA512 0a2aa310b9e1d51cb296be87df5d7c87bdf9daa3a61151ff3a2bca9d58bd2c369c7fa8dfad134d23a00cc034a8c8cd9ff2a326e8883ecad43457604762b42242
diff --git a/dev-db/sqlmap/sqlmap-1.7.9.ebuild b/dev-db/sqlmap/sqlmap-1.7.9.ebuild
new file mode 100644
index 000000000000..98dd6c54846c
--- /dev/null
+++ b/dev-db/sqlmap/sqlmap-1.7.9.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit bash-completion-r1 python-single-r1 wrapper
+
+DESCRIPTION="An automatic SQL injection and database takeover tool"
+HOMEPAGE="https://sqlmap.org/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sqlmapproject/sqlmap"
+else
+ SRC_URI="https://github.com/sqlmapproject/sqlmap/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# sqlmap (GPL-2+)
+# ansitrm (BSD)
+# beautifulsoup (BSD)
+# bottle (MIT)
+# chardet (LGPL-2.1+)
+# clientform (BSD)
+# colorama (BSD)
+# fcrypt (BSD-2)
+# identitywaf (MIT)
+# keepalive (LGPL-2.1+)
+# magic (MIT)
+# multipartpost (LGPL-2.1+)
+# ordereddict (MIT)
+# prettyprint (BSD-2)
+# pydes (public-domain)
+# six (MIT)
+# socks (BSD)
+# termcolor (BSD)
+# wininetpton (public-domain)
+LICENSE="BSD BSD-2 GPL-2+ LGPL-2.1+ MIT public-domain"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=( doc/ README.md )
+
+src_install () {
+ einstalldocs
+
+ insinto /usr/share/${PN}/
+ doins -r *
+ python_optimize "${ED}"/usr/share/${PN}
+
+ make_wrapper ${PN} \
+ "${EPYTHON} ${EPREFIX}/usr/share/${PN}/sqlmap.py"
+
+ newbashcomp "${FILESDIR}"/sqlmap.bash-completion sqlmap
+}
diff --git a/dev-db/sqlmap/sqlmap-9999.ebuild b/dev-db/sqlmap/sqlmap-9999.ebuild
index 550ec7d5d4b0..98dd6c54846c 100644
--- a/dev-db/sqlmap/sqlmap-9999.ebuild
+++ b/dev-db/sqlmap/sqlmap-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="sqlite"
inherit bash-completion-r1 python-single-r1 wrapper