summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-20 18:14:25 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 20:51:39 +0200
commita8ed914a53b5e5654b5d9aeb8a07573dc77ad228 (patch)
treeb24ebdc730e46348dfe2b62ce3bb7c3413a51ea8 /app-text/ocrad
parentapp-text/bdf2psf: fix LICENSE, use HTTPS (diff)
downloadgentoo-a8ed914a53b5e5654b5d9aeb8a07573dc77ad228.tar.gz
gentoo-a8ed914a53b5e5654b5d9aeb8a07573dc77ad228.tar.bz2
gentoo-a8ed914a53b5e5654b5d9aeb8a07573dc77ad228.zip
app-text/ocrad: add 0.29
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-text/ocrad')
-rw-r--r--app-text/ocrad/Manifest1
-rw-r--r--app-text/ocrad/ocrad-0.29.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-text/ocrad/Manifest b/app-text/ocrad/Manifest
index e2db2e2b29da..a772136b8bff 100644
--- a/app-text/ocrad/Manifest
+++ b/app-text/ocrad/Manifest
@@ -1 +1,2 @@
DIST ocrad-0.27.tar.lz 91709 BLAKE2B 4dd152e6ccbd41d2ce7e7e3d4fc38e30af4f0bb9c36e32b1f32e67772347af133cf67a8b89c03d5c9924a1d4ffa009205b80609cdb96a59b3dbeb76709a8e8e1 SHA512 2a4731e0e26eefe6d37b08859c4d3cc2b54180411b0f846f7b7e873b9da5b4596ca3c6042ee42284a07aadfeb96d953dce3e95ce2410e48624d1b6020750539c
+DIST ocrad-0.29.tar.lz 96519 BLAKE2B b5acb8fa3b3f02b7a0e5697b3ab4aa4ecc115c9d668192d6a4f533b787092c91449366df3603c73b926be61e5cb6b4e2d5406896ec79f931eb42dce104a424c5 SHA512 92503fbdb1877d9f8d4516fb7ba1c032868f5b3244f6547441a8a2bd84ff9f1c5a60c7347d748581e5f03014c2b7d2a8692bb4ecc3eacf18e2bf2232306976a8
diff --git a/app-text/ocrad/ocrad-0.29.ebuild b/app-text/ocrad/ocrad-0.29.ebuild
new file mode 100644
index 000000000000..475d5d889a67
--- /dev/null
+++ b/app-text/ocrad/ocrad-0.29.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo unpacker toolchain-funcs
+
+DESCRIPTION="OCR (Optical Character Recognition) program"
+HOMEPAGE="https://www.gnu.org/software/ocrad/ocrad.html"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+BDEPEND="$(unpacker_src_uri_depends)"
+
+src_configure() {
+ # ./configure is not based on autotools
+ edo ./configure \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ --prefix=/usr
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ doman doc/${PN}.1
+ doinfo doc/${PN}.info
+}