summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-portage/tatt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-portage/tatt')
-rw-r--r--app-portage/tatt/Manifest1
-rw-r--r--app-portage/tatt/metadata.xml22
-rw-r--r--app-portage/tatt/tatt-0.3.ebuild37
-rw-r--r--app-portage/tatt/tatt-9999.ebuild37
4 files changed, 97 insertions, 0 deletions
diff --git a/app-portage/tatt/Manifest b/app-portage/tatt/Manifest
new file mode 100644
index 000000000000..0c1a9466e785
--- /dev/null
+++ b/app-portage/tatt/Manifest
@@ -0,0 +1 @@
+DIST tatt-0.3.tar.gz 22527 SHA256 bad1f0f33889aaa5887bab8c80bcbdaa620c379de5ff381ab983ae23d24ac9ed SHA512 822ec8904e452afd2373ca7ff01a05b8020b261acfc02864523a22e91d83dea51a1d2a8c79ec75db38e6de00cb3c06b3799dee261f376ec91d261a9f468aaa19 WHIRLPOOL f9be83b45c3d79e004600fa3e1ecd2d1ab6e6720035f13ab5f0b4a46555c280663e6371fb9ed88ab0de6bbfb4a853a0f07963dbc25f668a3cd8482c369343b90
diff --git a/app-portage/tatt/metadata.xml b/app-portage/tatt/metadata.xml
new file mode 100644
index 000000000000..d8f38b33dba7
--- /dev/null
+++ b/app-portage/tatt/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tomka@gentoo.org</email>
+ <name>Thomas Kahle</name>
+ </maintainer>
+ <maintainer>
+ <email>fauli@gentoo.org</email>
+ <name>Christian Faulhammer</name>
+ </maintainer>
+ <use>
+ <flag name="templates">Install template scripts to be used with tatt</flag>
+ </use>
+ <longdescription lang="en">
+Tatt arch testing tool can be use to automatically generate scripts for various boring tasks during arch work.
+It aims at developers. If you are a normal user you will not need tatt.
+</longdescription>
+ <upstream>
+ <remote-id type="github">tom111/tatt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-portage/tatt/tatt-0.3.ebuild b/app-portage/tatt/tatt-0.3.ebuild
new file mode 100644
index 000000000000..ad1bc15e3c34
--- /dev/null
+++ b/app-portage/tatt/tatt-0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="tatt is an arch testing tool"
+HOMEPAGE="https://github.com/tom111/tatt"
+SRC_URI="https://github.com/tom111/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+templates"
+
+RDEPEND="
+ app-portage/eix
+ app-portage/gentoolkit
+ www-client/pybugz
+ dev-python/configobj[${PYTHON_USEDEP}]"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use templates; then
+ insinto "/usr/share/${PN}"
+ doins -r templates
+ fi
+ doman tatt.1
+ doman tatt.5
+}
diff --git a/app-portage/tatt/tatt-9999.ebuild b/app-portage/tatt/tatt-9999.ebuild
new file mode 100644
index 000000000000..e97834d1f64e
--- /dev/null
+++ b/app-portage/tatt/tatt-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="arch testing tool"
+HOMEPAGE="http://github.com/tom111/tatt"
+EGIT_REPO_URI="https://github.com/tom111/tatt.git \
+ git://github.com/tom111/tatt.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="+templates"
+
+RDEPEND="
+ app-portage/eix
+ app-portage/gentoolkit
+ www-client/pybugz
+ dev-python/configobj[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use templates; then
+ insinto "/usr/share/${PN}"
+ doins -r templates
+ fi
+ doman tatt.1
+ doman tatt.5
+}