summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-11-16 13:15:46 +0200
committerMart Raudsepp <leio@gentoo.org>2019-11-16 13:16:14 +0200
commitbc3c29fd8bde463e6209b01ff6995c0b7c137db7 (patch)
tree9590a72f4d7205a512955be28682c3c34e16584f /app-i18n/poedit/poedit-2.2.4.ebuild
parentdev-python/zope-interface: Fix MissingTestRestrict (diff)
downloadgentoo-bc3c29fd8bde463e6209b01ff6995c0b7c137db7.tar.gz
gentoo-bc3c29fd8bde463e6209b01ff6995c0b7c137db7.tar.bz2
gentoo-bc3c29fd8bde463e6209b01ff6995c0b7c137db7.zip
app-i18n/poedit: bump to 2.2.4
Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-i18n/poedit/poedit-2.2.4.ebuild')
-rw-r--r--app-i18n/poedit/poedit-2.2.4.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-i18n/poedit/poedit-2.2.4.ebuild b/app-i18n/poedit/poedit-2.2.4.ebuild
new file mode 100644
index 000000000000..fd485f8975e8
--- /dev/null
+++ b/app-i18n/poedit/poedit-2.2.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PLOCALES="af an ar az be be@latin bg bs ca ckb co cs da de el en_GB es et eu fa fi fr ga gl he hr hu hy id is it ja ka kab kk ko lt lv ms nb nl oc pa pl pt_BR pt_PT ro ru sk sl sq sr sv tg th tr uk uz vi zh_CN zh_TW"
+WX_GTK_VER=3.0-gtk3
+
+inherit gnome2-utils l10n wxwidgets xdg
+
+DESCRIPTION="GUI gettext translations editor"
+HOMEPAGE="https://poedit.net"
+SRC_URI="https://github.com/vslavik/${PN}/releases/download/v${PV}-oss/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-text/gtkspell:3
+ x11-libs/gtk+:3
+ >=dev-cpp/lucene++-3.0.5
+ >=dev-libs/pugixml-1.9
+ dev-libs/boost:=[nls]
+ dev-libs/icu:=
+ >=x11-libs/wxGTK-3.0.3:${WX_GTK_VER}[X]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ my_rm_loc() {
+ sed -i -e "/^POEDIT_LINGUAS = /s: ${1}::" locales/Makefile.in || die
+ rm "locales/${1}.mo" || die
+ }
+
+ l10n_find_plocales_changes 'locales' '' '.mo'
+ l10n_for_each_disabled_locale_do my_rm_loc
+
+ setup-wxwidgets
+ xdg_src_prepare
+}
+
+src_configure() {
+ # CLD2 and C++ Rest are not available in Gentoo, bug 674916
+ local myeconfargs=(
+ --without-cld2
+ --without-cpprest
+ )
+
+ econf "${myeconfargs[@]}"
+}