summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-06 20:20:42 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-06 21:51:30 +0200
commitafa092ba14a1c95f7daf9199fd65216c7e271a50 (patch)
tree2cc3045a5345dd68e4d0795343bc710ba261ac7f /app-emacs
parentapp-emacs/deferred: minor tweaks (diff)
downloadgentoo-afa092ba14a1c95f7daf9199fd65216c7e271a50.tar.gz
gentoo-afa092ba14a1c95f7daf9199fd65216c7e271a50.tar.bz2
gentoo-afa092ba14a1c95f7daf9199fd65216c7e271a50.zip
app-emacs/ht: minor tweaks
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ht/ht-2.3.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/app-emacs/ht/ht-2.3.ebuild b/app-emacs/ht/ht-2.3.ebuild
index 57af14755328..c5b952f5298a 100644
--- a/app-emacs/ht/ht-2.3.ebuild
+++ b/app-emacs/ht/ht-2.3.ebuild
@@ -7,14 +7,21 @@ inherit elisp
DESCRIPTION="The missing hash table library for Emacs"
HOMEPAGE="https://github.com/Wilfred/ht.el"
-SRC_URI="https://github.com/Wilfred/ht.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/ht.el-${PV}"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Wilfred/ht.el.git"
+else
+ SRC_URI="https://github.com/Wilfred/ht.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/ht.el-${PV}"
+
+ KEYWORDS="amd64 ~arm64"
+fi
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="amd64 ~arm64"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
>=app-emacs/dash-2.12.0
@@ -23,13 +30,10 @@ BDEPEND="
${RDEPEND}
test? (
app-emacs/f
- app-emacs/ert-runner
)
"
-DOCS="CHANGELOG.md README.md"
+DOCS=( CHANGELOG.md README.md )
SITEFILE="50${PN}-gentoo.el"
-src_test() {
- ert-runner --reporter ert+duration --script || die
-}
+elisp-enable-tests ert-runner .