summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/gnuplot-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/gnuplot-mode')
-rw-r--r--app-emacs/gnuplot-mode/Manifest1
-rw-r--r--app-emacs/gnuplot-mode/files/50gnuplot-mode-gentoo.el6
-rw-r--r--app-emacs/gnuplot-mode/gnuplot-mode-0.7.0.ebuild44
-rw-r--r--app-emacs/gnuplot-mode/metadata.xml8
4 files changed, 59 insertions, 0 deletions
diff --git a/app-emacs/gnuplot-mode/Manifest b/app-emacs/gnuplot-mode/Manifest
new file mode 100644
index 000000000000..1f3efd53e5b6
--- /dev/null
+++ b/app-emacs/gnuplot-mode/Manifest
@@ -0,0 +1 @@
+DIST gnuplot-mode-0.7.0.tar.gz 373475 SHA256 310018d8c313ebd817e3e6116ab28eb2b848fa0992917b5ee4148d6073f59f3e SHA512 fdf04a3a32755892d422de8a535682ff44d1b635ecdc814738564376f5c7027a82c23807439835f2b7bf959f4f8b7a7d38d07a643f84ab2056ba187f3558e596 WHIRLPOOL 77f98735fd0fa6e1379278aaaeacf2834d2fad3c5ed3f56b4232215142a1c8336c4d7375282856fa4fe754dfaae2500027f9022f5c2799e90571af57e8be783d
diff --git a/app-emacs/gnuplot-mode/files/50gnuplot-mode-gentoo.el b/app-emacs/gnuplot-mode/files/50gnuplot-mode-gentoo.el
new file mode 100644
index 000000000000..e79a7f0d2585
--- /dev/null
+++ b/app-emacs/gnuplot-mode/files/50gnuplot-mode-gentoo.el
@@ -0,0 +1,6 @@
+(add-to-list 'load-path "@SITELISP@")
+;; extracted from dotemacs file distributed with the source tarball
+(autoload 'gnuplot-mode "gnuplot" "gnuplot major mode" t)
+(autoload 'gnuplot-make-buffer "gnuplot" "open a buffer in gnuplot mode" t)
+(add-to-list 'auto-mode-alist '("\\.gp\\'" . gnuplot-mode))
+;;(global-set-key [(f9)] 'gnuplot-make-buffer)
diff --git a/app-emacs/gnuplot-mode/gnuplot-mode-0.7.0.ebuild b/app-emacs/gnuplot-mode/gnuplot-mode-0.7.0.ebuild
new file mode 100644
index 000000000000..e5947134fe66
--- /dev/null
+++ b/app-emacs/gnuplot-mode/gnuplot-mode-0.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+DESCRIPTION="Gnuplot mode for Emacs"
+HOMEPAGE="http://xafs.org/BruceRavel/GnuplotMode"
+SRC_URI="https://github.com/bruceravel/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="doc? ( virtual/latex-base )"
+RDEPEND="sci-visualization/gnuplot[-emacs(-)]"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf \
+ EMACS="${EMACS}" \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}"
+}
+
+src_compile() {
+ emake
+ use doc && emake pdf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ dodoc README.org
+ use doc && dodoc gpelcard.pdf
+
+ DOC_CONTENTS="Please see ${SITELISP}/${PN}/gnuplot.el for the
+ complete documentation."
+ readme.gentoo_create_doc
+}
diff --git a/app-emacs/gnuplot-mode/metadata.xml b/app-emacs/gnuplot-mode/metadata.xml
new file mode 100644
index 000000000000..536405d4b31c
--- /dev/null
+++ b/app-emacs/gnuplot-mode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="github">bruceravel/gnuplot-mode</remote-id>
+</upstream>
+</pkgmetadata>