summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-04 09:15:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-04 10:06:19 +0200
commit026afb49a0f45ec901c9091a291619ce369b7ef1 (patch)
tree04e639991808e1724390b3c140f6a12bcb0c8e97 /app-arch/xarchiver
parentdev-python/zeroconf: Bump to 0.62.0 (diff)
downloadgentoo-026afb49a0f45ec901c9091a291619ce369b7ef1.tar.gz
gentoo-026afb49a0f45ec901c9091a291619ce369b7ef1.tar.bz2
gentoo-026afb49a0f45ec901c9091a291619ce369b7ef1.zip
app-arch/xarchiver: Bump to 0.5.4.21
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/xarchiver')
-rw-r--r--app-arch/xarchiver/Manifest1
-rw-r--r--app-arch/xarchiver/xarchiver-0.5.4.21.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-arch/xarchiver/Manifest b/app-arch/xarchiver/Manifest
index 1f4bef629452..42ecfb920e9e 100644
--- a/app-arch/xarchiver/Manifest
+++ b/app-arch/xarchiver/Manifest
@@ -1 +1,2 @@
DIST xarchiver-0.5.4.20.tar.gz 1120317 BLAKE2B dbeb21492a4045d504aac92c28847a91c23e0feedeb82074fe89736f64b2b7d09b41bbefe321441c51736a8273267ac13dd616d4f61ba1b9e72cc805e749aa79 SHA512 c05be6f69a576988ca1a67c1664e4e4e3c53588ef4c85ce943e204ae72b08e705eb20be1018274c5420e30c5ed71d773bdacccc538ab458d658fba494c097777
+DIST xarchiver-0.5.4.21.tar.gz 1132417 BLAKE2B 38a426d4a7ac53a471aba7dec8d1da64e6bb4bab3d7efb5e8e1326dcbdfd1e98e66dab43d50cc847fb37ee754d8996233c23503f2a57776ed8e4b96da425462e SHA512 7befe5427636aaa27b669c503832927731cc9da27c698f3e2ea06d8b4579d95096613a41b54919eb3f9314791d32e73b6aecdb5e6af7b10dd154861377f2f5c4
diff --git a/app-arch/xarchiver/xarchiver-0.5.4.21.ebuild b/app-arch/xarchiver/xarchiver-0.5.4.21.ebuild
new file mode 100644
index 000000000000..7ac6a12c9715
--- /dev/null
+++ b/app-arch/xarchiver/xarchiver-0.5.4.21.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A GTK+ archive manager that can be used with Thunar"
+HOMEPAGE="https://github.com/ib/xarchiver/"
+SRC_URI="
+ https://github.com/ib/xarchiver/archive/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="
+ >=dev-libs/glib-2:=
+ x11-libs/gtk+:3=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "You need external programs for some formats, including:"
+ elog "7zip - app-arch/p7zip"
+ elog "arj - app-arch/arj"
+ elog "lha - app-arch/lha"
+ elog "lzop - app-arch/lzop"
+ elog "rar - app-arch/unrar app-arch/rar"
+ elog "zip - app-arch/unzip app-arch/zip"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}