summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-09-25 06:53:59 -0500
committerBen Kohler <bkohler@gentoo.org>2024-09-25 06:55:00 -0500
commit2437376d32200ccbd3444f06963eb72d4eea7a14 (patch)
tree4cbf755f32f6e90dbc2fb495b7768db3ce04a79d
parentnet-misc/dropbox: add 208.4.5824 (diff)
downloadgentoo-2437376d32200ccbd3444f06963eb72d4eea7a14.tar.gz
gentoo-2437376d32200ccbd3444f06963eb72d4eea7a14.tar.bz2
gentoo-2437376d32200ccbd3444f06963eb72d4eea7a14.zip
net-irc/ircii: add 20240918
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--net-irc/ircii/Manifest1
-rw-r--r--net-irc/ircii/ircii-20240918.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-irc/ircii/Manifest b/net-irc/ircii/Manifest
index da664954e08e..18cd3f4050bc 100644
--- a/net-irc/ircii/Manifest
+++ b/net-irc/ircii/Manifest
@@ -1 +1,2 @@
DIST ircii-20240111.tar.bz2 576700 BLAKE2B 785177e30dbe3b417aec9fb348574e4f539adcfef41534743c050d39aa0e0ba00ea52accc20b785a836f7496e66975549b85fa17a58c280d893f5c0927e1bb1b SHA512 4705b851671f89d1b4903539eb7e701913748138d460572bfeb7e6d565e760b9782aecb55d82c691f6f182864b12e78e13a7b5a1e3abcd535e5bc24c9815e1aa
+DIST ircii-20240918.tar.bz2 578232 BLAKE2B a636de6900805b040df834fa29e49da608693192ae1e5cfaa0cec00f1d95527401ff529bfb754f9c3a447ee85202bc22a6fc667d748a392ba1a959f4643fe0b6 SHA512 9aadafd2bf56e7d18ed78563553143113374830c8b072d125212a7e94a7057512f2ee8a77412749d9eb345596d0c054e18ec2f3d3e569c54e97db71d4c5b77f1
diff --git a/net-irc/ircii/ircii-20240918.ebuild b/net-irc/ircii/ircii-20240918.ebuild
new file mode 100644
index 000000000000..42b05199fb52
--- /dev/null
+++ b/net-irc/ircii/ircii-20240918.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An IRC and ICB client that runs under most UNIX platforms"
+HOMEPAGE="http://eterna23.net/ircii/"
+SRC_URI="https://ircii.warped.com/${P}.tar.bz2
+ https://ircii.warped.com/old/${P}.tar.bz2
+ https://dev.gentoo.org/~bkohler/dist/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="dev-libs/openssl:0=
+ sys-libs/ncurses:0=
+ virtual/libcrypt:=
+ virtual/libiconv"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-manpage-path.patch" )
+DOCS=( ChangeLog INSTALL NEWS README doc/Copyright doc/crypto doc/VERSIONS
+ doc/ctcp )
+
+src_configure() {
+ tc-export CC
+ # --with-lto only appends -flto (so does --without-lto, sigh)
+ econf
+}
+
+src_install() {
+ # Still needed as of 20221016, otherwise man dirs don't exist
+ # at the right time.
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+}