summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-06-27 20:20:38 -0400
committerAnthony G. Basile <blueness@gentoo.org>2012-06-27 20:20:38 -0400
commit387d41fdfec36d12276758e3029e79965095f057 (patch)
tree934acfe6a35c9f9c354a7fc4c4884b797b1430eb
parentAdd support for www-servers/nginx and www-servers/gatling (diff)
downloadwebapp-config-387d41fdfec36d12276758e3029e79965095f057.tar.gz
webapp-config-387d41fdfec36d12276758e3029e79965095f057.tar.bz2
webapp-config-387d41fdfec36d12276758e3029e79965095f057.zip
Remove examples
-rw-r--r--examples/phpmyadmin-2.5.4-r1.ebuild93
-rw-r--r--examples/phpmyadmin-2.5.4-r2.ebuild92
-rw-r--r--examples/postinstall-en.txt13
3 files changed, 0 insertions, 198 deletions
diff --git a/examples/phpmyadmin-2.5.4-r1.ebuild b/examples/phpmyadmin-2.5.4-r1.ebuild
deleted file mode 100644
index d84d7ad..0000000
--- a/examples/phpmyadmin-2.5.4-r1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /home/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.5.4.ebuild,v 1.6 2003/12/15 20:03:27 stuart Exp $
-
-inherit webapp
-
-MY_P=phpMyAdmin-${PV/_p/-pl}
-DESCRIPTION="Web-based administration for MySQL database in PHP"
-HOMEPAGE="http://phpmyadmin.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}-php.tar.bz2"
-RESTRICT="nomirror"
-LICENSE="GPL-2"
-KEYWORDS="alpha arm ppc hppa mips sparc x86 amd64"
-DEPEND=">=net-www/apache-1.3
- >=dev-db/mysql-3.21 <dev-db/mysql-5.0
- >=dev-php/mod_php-3.0.8
- sys-apps/findutils"
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- epatch ${FILESDIR}/config.inc.php-${PV}.patch
-
- # Remove .cvs* files and CVS directories
- find ${S} -name .cvs\* -or \( -type d -name CVS -prune \) | xargs rm -rf
-}
-
-src_compile() {
- einfo "Setting random user/password details for the controluser"
-
- local pmapass="${RANDOM}${RANDOM}${RANDOM}${RANDOM}"
- mv config.inc.php ${T}/config.inc.php
- sed -e "s/@pmapass@/${pmapass}/g" \
- ${T}/config.inc.php > config.inc.php
- sed -e "s/@pmapass@/${pmapass}/g" \
- ${FILESDIR}/mysql-setup.sql.in-${PV} > ${T}/mysql-setup.sql
-}
-
-src_install() {
- webapp_src_preinst
-
- local docs="ANNOUNCE.txt CREDITS Documentation.txt RELEASE-DATE-${PV} TODO ChangeLog LICENSE README"
-
- # install the SQL scripts available to us
- #
- # unfortunately, we do not have scripts to upgrade from older versions
- # these are things we need to add at a later date
-
- webapp_sqlscript mysql ${T}/mysql-setup.sql
-
- # handle documentation files
- #
- # NOTE that doc files go into /usr/share/doc as normal; they do NOT
- # get installed per vhost!
-
- dodoc ${docs}
- for doc in ${docs} INSTALL; do
- rm -f ${doc}
- done
-
- # Copy the app's main files
-
- einfo "Installing main files"
- cp -r . ${D}${MY_HTDOCSDIR}
-
- # Identify the configuration files that this app uses
-
- webapp_configfile ${MY_HTDOCSDIR}/config.inc.php
-
- # Identify any script files that need #! headers adding to run under
- # a CGI script (such as PHP/CGI)
- #
- # for phpmyadmin, we *assume* that all .php files that don't end in
- # .inc.php need to have CGI/BIN support added
-
- for x in `find . -name '*.php' -print | grep -v 'inc.php'` ; do
- webapp_runbycgibin php ${MY_HTDOCSDIR}/$x
- done
-
- # there are no files which need to be owned by the web server
-
- webapp_serverowned ${MY_HTDOCSDIR}
-
- # add the post-installation instructions
-
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
-
- # all done
- #
- # now we let the eclass strut its stuff ;-)
-
- webapp_src_install
-}
diff --git a/examples/phpmyadmin-2.5.4-r2.ebuild b/examples/phpmyadmin-2.5.4-r2.ebuild
deleted file mode 100644
index 88beeb1..0000000
--- a/examples/phpmyadmin-2.5.4-r2.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /home/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.5.4.ebuild,v 1.6 2003/12/15 20:03:27 stuart Exp $
-
-inherit eutils
-inherit webapp
-
-MY_P=phpMyAdmin-${PV/_p/-pl}
-DESCRIPTION="Web-based administration for MySQL database in PHP"
-HOMEPAGE="http://phpmyadmin.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}-php.tar.bz2"
-RESTRICT="nomirror"
-LICENSE="GPL-2"
-KEYWORDS="alpha arm ppc hppa mips sparc x86 amd64"
-DEPEND=">=net-www/apache-1.3
- >=dev-db/mysql-3.21 <dev-db/mysql-5.0
- >=dev-php/mod_php-3.0.8
- sys-apps/findutils"
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- epatch ${FILESDIR}/config.inc.php-${PV}.patch
-
- # Remove .cvs* files and CVS directories
- find ${S} -name .cvs\* -or \( -type d -name CVS -prune \) | xargs rm -rf
-}
-
-src_compile() {
- einfo "Setting random user/password details for the controluser"
-
- local pmapass="${RANDOM}${RANDOM}${RANDOM}${RANDOM}"
- mv config.inc.php ${T}/config.inc.php
- sed -e "s/@pmapass@/${pmapass}/g" \
- ${T}/config.inc.php > config.inc.php
- sed -e "s/@pmapass@/${pmapass}/g" \
- ${FILESDIR}/mysql-setup.sql.in-${PV} > ${T}/mysql-setup.sql
-}
-
-src_install() {
- webapp_src_preinst
-
- local docs="ANNOUNCE.txt CREDITS Documentation.txt RELEASE-DATE-${PV} TODO ChangeLog LICENSE README"
-
- # install the SQL scripts available to us
- #
- # unfortunately, we do not have scripts to upgrade from older versions
- # these are things we need to add at a later date
-
- webapp_sqlscript mysql ${T}/mysql-setup.sql
-
- # handle documentation files
- #
- # NOTE that doc files go into /usr/share/doc as normal; they do NOT
- # get installed per vhost!
-
- dodoc ${docs}
- for doc in ${docs} INSTALL; do
- rm -f ${doc}
- done
-
- # Copy the app's main files
-
- einfo "Installing main files"
- cp -r . ${D}${MY_HTDOCSDIR}
-
- # Identify the configuration files that this app uses
-
- webapp_configfile ${MY_HTDOCSDIR}/config.inc.php
-
- # Identify any script files that need #! headers adding to run under
- # a CGI script (such as PHP/CGI)
- #
- # for phpmyadmin, we *assume* that all .php files that don't end in
- # .inc.php need to have CGI/BIN support added
-
- for x in `find . -name '*.php' -print | grep -v 'inc.php'` ; do
- webapp_runbycgibin php ${MY_HTDOCSDIR}/$x
- done
-
- # there are no files which need to be owned by the web server
-
- # add the post-installation instructions
-
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
-
- # all done
- #
- # now we let the eclass strut its stuff ;-)
-
- webapp_src_install
-}
diff --git a/examples/postinstall-en.txt b/examples/postinstall-en.txt
deleted file mode 100644
index 4bd19f0..0000000
--- a/examples/postinstall-en.txt
+++ /dev/null
@@ -1,13 +0,0 @@
-To complete installation, you must
-
-1. Update MySQL's grant tables and the pmadb database:
- mysql -u root -p < ${MY_SQLSCRIPTSDIR}/mysql/${PVR}_create.sql
-2. Reload MySQL:
- /etc/init.d/mysql restart
-
-If you are upgrading from an earlier version and are using phpMyAdmin's
-features for master/foreign tables be sure to read
- http://localhost/phpmyadmin/Documentation.html#col_com
-You will need to perform the ALTER TABLE step yourself.
-
-Finally, point your browser to http://localhost/phpmyadmin/.