aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-24 12:35:32 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-24 12:36:04 +0100
commitff716ae3e8852218b24ff4c29a72a490459d5f22 (patch)
treef1d8a22b9a36d91595953be273a72c114149d820 /media-libs
parentmedia-gfx/brlcad: version bump 7.32.0 (diff)
downloadsci-ff716ae3e8852218b24ff4c29a72a490459d5f22.tar.gz
sci-ff716ae3e8852218b24ff4c29a72a490459d5f22.tar.bz2
sci-ff716ae3e8852218b24ff4c29a72a490459d5f22.zip
media-libs/implicitmesher: update snapshot
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/implicitmesher/Manifest1
-rw-r--r--media-libs/implicitmesher/files/implicitmesher-0_glm.patch44
-rw-r--r--media-libs/implicitmesher/implicitmesher-0_p20200413.ebuild (renamed from media-libs/implicitmesher/implicitmesher-0_p20191111.ebuild)12
3 files changed, 32 insertions, 25 deletions
diff --git a/media-libs/implicitmesher/Manifest b/media-libs/implicitmesher/Manifest
new file mode 100644
index 000000000..2feca3fdf
--- /dev/null
+++ b/media-libs/implicitmesher/Manifest
@@ -0,0 +1 @@
+DIST implicitmesher-0_p20200413.tar.gz 23224 BLAKE2B fd7d10406f56c88a42821b5aa9848d228317147e4a7d8283b13719ebd9a6e57fecc5b4fb140c1ae23da16e45f90332d9953d5daa1be80ec633c7c011342f00f5 SHA512 5641a44d8a02ef3868d23e92afb053556e775f5beeb5d618dabf7d3e3f19a0a597693134524be2d92387481306af89d8be54c1677fa61fa111dae72ed25b3ea4
diff --git a/media-libs/implicitmesher/files/implicitmesher-0_glm.patch b/media-libs/implicitmesher/files/implicitmesher-0_glm.patch
index c3707e210..2f1841f4d 100644
--- a/media-libs/implicitmesher/files/implicitmesher-0_glm.patch
+++ b/media-libs/implicitmesher/files/implicitmesher-0_glm.patch
@@ -1,34 +1,38 @@
-Index: implicitmesher-0_p20191111/CMakeLists.txt
-===================================================================
---- implicitmesher-0_p20191111.orig/CMakeLists.txt
-+++ implicitmesher-0_p20191111/CMakeLists.txt
-@@ -3,19 +3,12 @@ set(name ImplicitMesher)
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d1a0cf3..f9013cb 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,7 +1,6 @@
+ cmake_minimum_required (VERSION 3.5)
+ set(name ImplicitMesher)
project(${name} VERSION 0.1.0)
-
- include(CTest)
-include(OpticksBuildOptions)
--
--include(GNUInstallDirs)
--set(CMAKE_INSTALL_INCLUDEDIR "externals/include/${name}")
--set(CMAKE_INSTALL_LIBDIR "externals/lib")
--set(CMAKE_INSTALL_BINDIR "lib")
--set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_FULL_LIBDIR}")
- find_package(BCM REQUIRED)
- include(BCMDeploy)
- #include(EchoTarget)
+ #[=[
+ Hmm OpticksBuildOptions sets CMAKE_INSTALL_INCLUDEDIR to "include/${name}"
+@@ -14,7 +13,7 @@ set(CMAKE_INSTALL_LIBDIR "externals/lib")
+ set(CMAKE_INSTALL_BINDIR "lib")
+
-find_package(GLM REQUIRED)
-+find_package(glm REQUIRED)
++find_package(glm REQUIRED)
set(SOURCES
-@@ -45,7 +38,7 @@ set(HEADERS
+@@ -44,7 +43,7 @@ set(HEADERS
)
add_library(${name} SHARED ${SOURCES})
-target_link_libraries(${name} PUBLIC Opticks::GLM)
+target_link_libraries(${name} PUBLIC glm)
- # needed for tests that use non-installed headers
- target_include_directories(${name} PUBLIC
+ if(UNIX AND NOT APPLE)
+ message(STATUS "adding stdc++ m for UNIX AND NOT APPLE")
+@@ -74,7 +73,6 @@ if(PC_VERBOSE)
+ endif()
+
+
+-bcm_deploy(TARGETS ${name} NAMESPACE Opticks:: SKIP_HEADER_INSTALL)
+ install(FILES ${HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+ add_subdirectory(tests)
diff --git a/media-libs/implicitmesher/implicitmesher-0_p20191111.ebuild b/media-libs/implicitmesher/implicitmesher-0_p20200413.ebuild
index 92156267e..e6fae861d 100644
--- a/media-libs/implicitmesher/implicitmesher-0_p20191111.ebuild
+++ b/media-libs/implicitmesher/implicitmesher-0_p20200413.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit mercurial cmake-utils
+inherit cmake
-EHG_REPO_URI="https://bitbucket.org/simoncblyth/${PN}"
-EHG_REVISION="a087394946d788bfd35a20b4b07909fa62f76a7a"
+COMMIT="4b7a47056074"
DESCRIPTION="Real-time implicit surface polygonization"
HOMEPAGE="https://bitbucket.org/simoncblyth/implicitmesher"
+SRC_URI="https://bitbucket.org/simoncblyth/implicitmesher/get/${COMMIT}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -18,6 +18,8 @@ KEYWORDS="~amd64"
RDEPEND="media-libs/glm"
DEPEND="${RDEPEND}"
+S="${WORKDIR}/simoncblyth-${PN}-${COMMIT}"
+
PATCHES=( "${FILESDIR}"/implicitmesher-0_glm.patch )
src_configure() {
@@ -25,5 +27,5 @@ src_configure() {
-DCMAKE_INSTALL_INCLUDEDIR=include/ImplicitMesher
)
- cmake-utils_src_configure
+ cmake_src_configure
}