aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-07-28 02:13:35 +0300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-07-28 02:13:35 +0300
commitafffdb82731793c43b533b458fd99971d655051c (patch)
tree22a069c480f7e228b09951e9c223278e3dcd9f3d
parentriscv: add latest spec files (diff)
downloadreleng-afffdb82731793c43b533b458fd99971d655051c.tar.gz
releng-afffdb82731793c43b533b458fd99971d655051c.tar.bz2
releng-afffdb82731793c43b533b458fd99971d655051c.zip
Add first experimental riscv catalyst-auto-riscv.conf
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--tools/catalyst-auto-riscv.conf51
1 files changed, 51 insertions, 0 deletions
diff --git a/tools/catalyst-auto-riscv.conf b/tools/catalyst-auto-riscv.conf
new file mode 100644
index 00000000..843b7da4
--- /dev/null
+++ b/tools/catalyst-auto-riscv.conf
@@ -0,0 +1,51 @@
+# This is the config file for the catalyst-auto script. It should be pretty
+# self-explanatory.
+
+ARCH="riscv"
+host=$(hostname)
+
+SPECS_DIR=${REPO_DIR}/releases/specs/${ARCH}
+
+SETS="
+ multilib
+ lp64d
+ lp64
+"
+
+SET_multilib_SPECS="stage1-multilib.spec stage2-multilib.spec stage3-multilib.spec"
+SET_lp64d_SPECS="stage1-lp64d.spec stage2-lp64d.spec stage3-lp64d.spec"
+SET_lp64_SPECS="stage1-lp64.spec stage2-lp64.spec stage3-lp64.spec"
+
+#KCONFIG_DIR=${REPO_DIR}/releases/kconfig/${ARCH}
+
+update_symlinks() {
+ # Symlink the latest stages3 to build from
+ local d f
+ for d in "${BUILD_SRCDIR_BASE}/builds/default" ; do
+ pushd "${d}" >/dev/null
+ for f in $(ls stage3*xz | grep -v latest | give_latest_from_dates) ; do
+ local of=$(echo "${f}" | convert_filename)
+ ln -sf "${f}" "${of}"
+ done
+ popd >/dev/null
+ done
+}
+
+upload() {
+ echo NOT Uploading "$@"
+# rsync -e 'ssh -i /root/.ssh/id_rsa -o UserKnownHostsFile=/dev/null -o VerifyHostKeyDNS=yes -o StrictHostKeyChecking=no' "$@" alpha@releng-incoming.gentoo.org:
+}
+
+post_build() {
+ local set=$1 spec=$2
+
+ pushd "${BUILD_SRCDIR_BASE}/builds/default" >/dev/null
+
+ case ${spec} in
+ stage3*.spec)
+ upload stage3-$(echo ${spec}|sed -e 's:^stage3-::g' -e 's:\.spec$::g')-${TIMESTAMP}*.xz*
+ ;;
+ esac
+
+ popd >/dev/null
+}