aboutsummaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-28 05:29:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-21 16:57:40 +0100
commitd9a288ee78a16f1a849037207850ef7413bc7cb5 (patch)
tree6157ec71bd4fd1408526990964cd6d0d489eb507 /dev-qt
parentx11-terms/qterminal: fix layer-shell-qt dependency (diff)
downloadqt-d9a288ee78a16f1a849037207850ef7413bc7cb5.tar.gz
qt-d9a288ee78a16f1a849037207850ef7413bc7cb5.tar.bz2
qt-d9a288ee78a16f1a849037207850ef7413bc7cb5.zip
dev-qt/qtwebengine: fix build with GCC 15 (qt5)
Thanks to Ionen for finding the QUIC patch. We may end up needing more for qt5. Closes: https://bugs.gentoo.org/936416 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.15.13_p20240510-gcc15.patch35
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.15.14.9999.ebuild5
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.15.13_p20240510-gcc15.patch b/dev-qt/qtwebengine/files/qtwebengine-5.15.13_p20240510-gcc15.patch
new file mode 100644
index 00000000..d3073b6c
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-5.15.13_p20240510-gcc15.patch
@@ -0,0 +1,35 @@
+https://bugs.gentoo.org/936416
+
+Backport of two upstream commits:
+* https://chromium-review.googlesource.com/c/chromium/src/+/5512719
+* https://quiche.googlesource.com/quiche/+/c1af894e0f5c4f732a983e7c93227854e203570e%5E%21/#F0
+--- a/src/3rdparty/chromium/base/containers/id_map.h
++++ b/src/3rdparty/chromium/base/containers/id_map.h
+@@ -153,8 +153,8 @@ class IDMap final {
+ }
+
+ const Iterator& operator=(const Iterator& iter) {
+- map_ = iter.map;
+- iter_ = iter.iter;
++ map_ = iter.map_;
++ iter_ = iter.iter_;
+ Init();
+ return *this;
+ }
+--- a/src/3rdparty/chromium/net/third_party/quiche/src/quic/core/quic_interval_deque.h
++++ b/src/3rdparty/chromium/net/third_party/quiche/src/quic/core/quic_interval_deque.h
+@@ -198,12 +198,12 @@ class QUIC_NO_EXPORT QuicIntervalDeque {
+ Iterator operator+(difference_type amount) const {
+ Iterator copy = *this;
+ copy.index_ += amount;
+- DCHECK(copy.index_ < copy.deque_->size());
++ DCHECK(copy.index_ < copy.deque_->Size());
+ return copy;
+ }
+ Iterator& operator+=(difference_type amount) {
+ index_ += amount;
+- DCHECK(index_ < deque_->size());
++ DCHECK(index_ < deque_->Size());
+ return *this;
+ }
+ difference_type operator-(const Iterator& rhs) const {
diff --git a/dev-qt/qtwebengine/qtwebengine-5.15.14.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-5.15.14.9999.ebuild
index 0823ad43..c254ccbd 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.15.14.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.15.14.9999.ebuild
@@ -99,7 +99,10 @@ BDEPEND="${PYTHON_DEPS}
sys-devel/flex
"
-PATCHES=( "${WORKDIR}/${PATCHSET}" )
+PATCHES=(
+ "${WORKDIR}/${PATCHSET}"
+ "${FILESDIR}/${PN}-5.15.13_p20240510-gcc15.patch"
+)
python_check_deps() {
python_has_version "dev-python/html5lib[${PYTHON_USEDEP}]"