aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--Makefile12
2 files changed, 13 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..77482bd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+eselect-postgresql*
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..22dec4a
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,12 @@
+D := $(shell dirname $(realpath $(lastword $(MAKEFILE_LIST))))
+V := $(shell grep V $(D)/postgresql.eselect | grep -Po '[0-9.]+')
+
+all:
+ mkdir -p $(D)/eselect-postgresql-$(V)
+ cp $(D)/postgresql.eselect $(D)/eselect-postgresql-$(V)/
+ tar cjf $(D)/eselect-postgresql-$(V).tbz2 $(D)/eselect-postgresql-$(V)
+
+clean:
+ rm $(D)/eselect-postgresql-$(V)/postgresql.eselect
+ rmdir $(D)/eselect-postgresql-$(V)
+ rm $(D)/eselect-postgresql-$(V).tbz2