aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--system-auth.in6
2 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 13398ff..651b641 100644
--- a/Makefile
+++ b/Makefile
@@ -40,6 +40,10 @@ ifeq "$(MKTEMP)" "yes"
PAMFLAGS += -DHAVE_MKTEMP=1
endif
+ifeq "$(PAM_SSH)" "yes"
+PAMFLAGS += -DHAVE_PAM_SSH=1
+endif
+
ifeq "$(DEBUG)" "yes"
PAMFLAGS += -DDEBUG=debug
endif
diff --git a/system-auth.in b/system-auth.in
index 6cc19d1..eeba9ac 100644
--- a/system-auth.in
+++ b/system-auth.in
@@ -1,6 +1,9 @@
#if HAVE_ENV
auth required pam_env.so DEBUG
#endif
+#ifdef HAVE_PAM_SSH
+auth sufficient pam_ssh.so
+#endif
auth required pam_unix.so try_first_pass LIKEAUTH nullok DEBUG
account required pam_unix.so DEBUG
@@ -22,5 +25,8 @@ session required pam_env.so DEBUG
#if HAVE_MKTEMP
session optional pam_mktemp.so
#endif
+#ifdef HAVE_PAM_SSH
+session optional pam_ssh.so
+#endif
session required pam_unix.so DEBUG