aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--xml/SCAP/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/xml/SCAP/Makefile b/xml/SCAP/Makefile
index 3e1b440..f0b8628 100644
--- a/xml/SCAP/Makefile
+++ b/xml/SCAP/Makefile
@@ -1,3 +1,5 @@
+location = "dev.gentoo.org:public_html/docs/security_benchmarks"
+
all: report-gentoo-xccdf.html guide-gentoo-xccdf.html remediate-gentoo-xccdf.sh guide-gentoo-xccdf.docbook report-gentoo-oval.xml gentoo-ds.xml
report-gentoo-xccdf.html: gentoo-cpe.xml gentoo-xccdf.xml gentoo-oval.xml prep
@@ -27,4 +29,7 @@ prep:
-cp ~/tmp/gentoo-oval.xml ~/tmp/cpe-oval.xml
-sed -i 's|gentoo-oval.xml|cpe-oval.xml|g' ~/tmp/gentoo-cpe.xml
-.PHONY: all prep
+upload:
+ -pushd ~/tmp; scp gentoo-cpe.xml gentoo-xccdf.xml gentoo-oval.xml gentoo-ds.xml guide-gentoo-xccdf.html report-gentoo-oval.html report-gentoo-xccdf.html $(location)/; popd;
+
+.PHONY: all prep upload