aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile7
-rw-r--r--README.rst13
2 files changed, 20 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000000..53e0d060db
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,7 @@
+
+all: pypy-c
+
+pypy-c:
+ @echo "Building PyPy with JIT, it'll take about 40 minutes and 4G of RAM"
+ @sleep 3
+ rpython/bin/rpython -Ojit pypy/goal/targetpypystandalone.py
diff --git a/README.rst b/README.rst
index abc63852d1..688d611683 100644
--- a/README.rst
+++ b/README.rst
@@ -22,3 +22,16 @@ from files in the pypy/doc directory within the source repositories. Enjoy
and send us feedback!
the pypy-dev team <pypy-dev@python.org>
+
+Building
+========
+
+build with::
+
+ rpython/bin/rpython -Ojit pypy/goal/targetpypystandalone.py
+
+This ends up with ``pypy-c`` binary in the main pypy directory. We suggest
+to use virtualenv with the resulting pypy-c as the interpreter, you can
+find more details about various installation schemes here:
+
+http://doc.pypy.org/en/latest/getting-started.html#installing-pypy