aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hosek <phosek@google.com>2022-03-09 00:48:49 -0800
committerPetr Hosek <phosek@google.com>2022-03-10 10:18:37 -0800
commitf39a971d821097df1936469b3fd5ba6a9b8e4b69 (patch)
tree5be87f19d3432418977eeca26b8891554e3498e9 /runtimes
parent[AMDGPU] Use subreg encoding instead of reassign (diff)
downloadllvm-project-f39a971d821097df1936469b3fd5ba6a9b8e4b69.tar.gz
llvm-project-f39a971d821097df1936469b3fd5ba6a9b8e4b69.tar.bz2
llvm-project-f39a971d821097df1936469b3fd5ba6a9b8e4b69.zip
[CMake] Include runtimes test suites in check-all
Prior to this change, we would make check-all depend on check-runtimes which is a target that runs tests in the runtimes build. This means that the runtimes tests are going to run prior to other test suites in check-all, and if one of them fails, we won't run the other test suites at all. To address this issue, we instead collect the list of test suites and their dependencies from the runtimes subbuild, and include them in check-all, so a failure of runtimes test suite doesn't prevent other test suites from being executed. This addresses https://github.com/llvm/llvm-project/issues/54154. Differential Revision: https://reviews.llvm.org/D121276
Diffstat (limited to 'runtimes')
-rw-r--r--runtimes/CMakeLists.txt10
-rw-r--r--runtimes/Tests.cmake.in3
2 files changed, 13 insertions, 0 deletions
diff --git a/runtimes/CMakeLists.txt b/runtimes/CMakeLists.txt
index 86dc7fb75fda..613a28901d67 100644
--- a/runtimes/CMakeLists.txt
+++ b/runtimes/CMakeLists.txt
@@ -238,6 +238,16 @@ if(LLVM_INCLUDE_TESTS)
add_subdirectory(${LLVM_MAIN_SRC_DIR}/utils/llvm-lit
${CMAKE_CURRENT_BINARY_DIR}/llvm-lit)
endif()
+
+ if(LLVM_RUNTIMES_TARGET)
+ configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/Tests.cmake.in
+ ${LLVM_BINARY_DIR}/runtimes/${LLVM_RUNTIMES_TARGET}/Tests.cmake)
+ else()
+ configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/Tests.cmake.in
+ ${LLVM_BINARY_DIR}/runtimes/Tests.cmake)
+ endif()
endif()
get_property(SUB_COMPONENTS GLOBAL PROPERTY SUB_COMPONENTS)
diff --git a/runtimes/Tests.cmake.in b/runtimes/Tests.cmake.in
new file mode 100644
index 000000000000..4df40f237b3f
--- /dev/null
+++ b/runtimes/Tests.cmake.in
@@ -0,0 +1,3 @@
+set(RUNTIMES_LIT_TESTSUITES @RUNTIMES_LIT_TESTSUITES@)
+set(RUNTIMES_LIT_PARAMS @RUNTIMES_LIT_PARAMS@)
+set(RUNTIMES_LIT_EXTRA_ARGS @RUNTIMES_LIT_EXTRA_ARGS@)