summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Lattner <sabre@nondot.org>2006-06-02 18:21:11 +0000
committerChris Lattner <sabre@nondot.org>2006-06-02 18:21:11 +0000
commitd1fe870e080b6a2f8d82430a949f4c2c1980eac5 (patch)
tree22299e8cb345281c69465c0a6a21e21b2aef5716 /llvm/projects
parentFix build on systems with bad bison's (diff)
downloadllvm-project-d1fe870e080b6a2f8d82430a949f4c2c1980eac5.tar.gz
llvm-project-d1fe870e080b6a2f8d82430a949f4c2c1980eac5.tar.bz2
llvm-project-d1fe870e080b6a2f8d82430a949f4c2c1980eac5.zip
Fix build on systems with broken bison
llvm-svn: 28658
Diffstat (limited to 'llvm/projects')
-rw-r--r--llvm/projects/Stacker/lib/compiler/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/llvm/projects/Stacker/lib/compiler/Makefile b/llvm/projects/Stacker/lib/compiler/Makefile
index 8e67fbe3c18b..053df43694aa 100644
--- a/llvm/projects/Stacker/lib/compiler/Makefile
+++ b/llvm/projects/Stacker/lib/compiler/Makefile
@@ -11,4 +11,9 @@ ifdef PARSE_DEBUG
INCLUDES += -DPARSE_DEBUG
endif
+# Disable -pedantic for this library, as bison output isn't necessarily
+# -pedantic clean.
+CompileCommonOpts := $(filter-out -pedantic,$(CompileCommonOpts))
+CompileCommonOpts := $(filter-out -Wno-long-long,$(CompileCommonOpts))
+
$(ObjDir)/Lexer.o : $(PROJ_SRC_DIR)/StackerParser.h