aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Tenty <daltenty@ibm.com>2021-11-09 12:44:44 -0500
committerDavid Tenty <daltenty@ibm.com>2021-11-09 16:04:10 -0500
commit2b416b46479d2dbe749e90d7c5344f05b4e35abc (patch)
tree84e8a3409bdf48a53aa2b65bd8f31b5e68b7d73e /libcxxabi
parent[clang-format] Refactor SpaceBeforeParens to add options (diff)
downloadllvm-project-2b416b46479d2dbe749e90d7c5344f05b4e35abc.tar.gz
llvm-project-2b416b46479d2dbe749e90d7c5344f05b4e35abc.tar.bz2
llvm-project-2b416b46479d2dbe749e90d7c5344f05b4e35abc.zip
[libcxx][CI][AIX] Switch to LLVM_ENABLE_RUNTIMES
and to the new `runtimes` top level CMakeLists.txt since the old path is now deprecated. This requires a slight adjustment of the libcxxabi CMake, since there are required macro definitions we previously got via the `llvm/CMakeList.txt` path. Reviewed By: ldionne, #libc, #libc_abi Differential Revision: https://reviews.llvm.org/D113403
Diffstat (limited to 'libcxxabi')
-rw-r--r--libcxxabi/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt
index 027dafd03fa1..79862b4a0493 100644
--- a/libcxxabi/CMakeLists.txt
+++ b/libcxxabi/CMakeLists.txt
@@ -519,6 +519,12 @@ string(REPLACE ";" " " LIBCXXABI_CXX_FLAGS "${LIBCXXABI_CXX_FLAGS}")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${LIBCXXABI_CXX_FLAGS}")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${LIBCXXABI_C_FLAGS}")
+# On AIX, avoid picking up VMX extensions(i.e. vec_malloc) which would change
+# the default alignment of the allocators here.
+if (UNIX AND ${CMAKE_SYSTEM_NAME} MATCHES "AIX")
+ add_definitions("-D_XOPEN_SOURCE=700")
+endif()
+
#===============================================================================
# Setup Source Code
#===============================================================================