aboutsummaryrefslogtreecommitdiff
path: root/libc
diff options
context:
space:
mode:
authorTue Ly <lntue@google.com>2022-01-14 11:08:52 -0500
committerTue Ly <lntue@google.com>2022-01-14 11:10:05 -0500
commite11e973e68f89224c8aaddf38ea7859709f00306 (patch)
tree8ebae417987247e53c70f9a2263fe3b7b399a28c /libc
parent[flang] Fix a bug in the `flang` wrapper script (diff)
downloadllvm-project-e11e973e68f89224c8aaddf38ea7859709f00306.tar.gz
llvm-project-e11e973e68f89224c8aaddf38ea7859709f00306.tar.bz2
llvm-project-e11e973e68f89224c8aaddf38ea7859709f00306.zip
[libc] Update exhaustive testing documentations.
Diffstat (limited to 'libc')
-rw-r--r--libc/src/math/docs/add_math_function.md6
1 files changed, 6 insertions, 0 deletions
diff --git a/libc/src/math/docs/add_math_function.md b/libc/src/math/docs/add_math_function.md
index d2affca51b61..f605efa62840 100644
--- a/libc/src/math/docs/add_math_function.md
+++ b/libc/src/math/docs/add_math_function.md
@@ -111,6 +111,11 @@ order to find exceptional cases for your function's implementation.
```
libc/test/src/math/exhaustive/CMakeLists.txt
```
+- The template class `LlvmLibcExhaustiveTest` located at:
+```
+ libc/test/src/math/exhaustive/exhaustive_test.h
+```
+can be inherited for conveniently parallelizing the exhaustive tests.
### Performance tests
@@ -164,6 +169,7 @@ implementation (which is very often glibc).
- Build and Run exhaustive test (might take hours to run):
```
$ ninja libc.test.src.math.exhaustive.<func>_test
+ $ projects/libc/test/src/math/exhaustive/libc.test.src.math.exhaustive.<func>_test
```
- Build and Run performance test: