diff options
author | Thomas Bushnell, BSG <thomas@gnu.org> | 1996-08-30 23:40:22 +0000 |
---|---|---|
committer | Thomas Bushnell, BSG <thomas@gnu.org> | 1996-08-30 23:40:22 +0000 |
commit | 924840c54244fe16223c42a91c36ca976784043b (patch) | |
tree | e7090890ae159ec9938f3f545677408faba7fe88 /Makerules | |
parent | update from main archive 960829 (diff) | |
download | glibc-924840c54244fe16223c42a91c36ca976784043b.tar.gz glibc-924840c54244fe16223c42a91c36ca976784043b.tar.bz2 glibc-924840c54244fe16223c42a91c36ca976784043b.zip |
*** empty log message ***
Fri Aug 30 13:39:21 1996 Thomas Bushnell, n/BSG <thomas@gnu.ai.mit.edu>
* Makerules (BUILD_CFLAGS): Use @(common-objpfx) for config.h, not
$(..). Some rules (like sysdeps/posix/Makefile for mk-stdiolim)
do `cd' commands.
(sed-remove-objpfx): Don't substitute for $(objpfx) anymore;
$(common-objpfx) is good enough.
* Rules (common-generated): Provide default (empty) value.
(dummy.o, dummy.c, empty.o, empty.c): Put these in
$(common-generated), not $(generated), and without $(..).
(subdir_echo-distinfo): Treat $(common-generated) just like
$(generated).
(generated): Depend on the (suitably mutated) $(common-generated)
files too.
* Makerules (common-clean): Remove common-generated files too.
* sysdeps/mach/hurd/Makefile (generated): Don't put errnos.d and
stamp-errnos here.
(common-generated): Do put errnos.d and stamp-errnos here.
(rpath-link): Don't use +=; $(rpath-link) is a colon separated list.
* sysdeps/mach/hurd/Makefile (before-compile): Add auth; also add
auth to following rule to get it built.
$(common-objpfx). All uses in dependency lists changed.
Diffstat (limited to 'Makerules')
-rw-r--r-- | Makerules | 5 |
1 files changed, 2 insertions, 3 deletions
@@ -289,8 +289,6 @@ endef ifneq (,$(objpfx)) # Continuation lines here are dangerous because they introduce spaces! define sed-remove-objpfx --e 's@ $(subst .,\.,$(subst @,\@,$(objpfx)))@ $$(objpfx)@g' \ --e 's@^$(subst .,\.,$(subst @,\@,$(objpfx)))@$$(objpfx)@g' \ -e 's@ $(subst .,\.,$(subst @,\@,$(common-objpfx)))@ $$(common-objpfx)@g' \ -e 's@^$(subst .,\.,$(subst @,\@,$(common-objpfx)))@$$(common-objpfx)@g' endef @@ -735,7 +733,7 @@ cd $(@D); $(BUILD_CC) $(BUILD_CFLAGS) $(<:$(common-objpfx)%=%) -o $(@F) endef # We always want to use configuration definitions. -BUILD_CFLAGS = -include $(..)config.h +BUILD_CFLAGS = -include $(common-objpfx)config.h # Support the GNU standard name for this target. .PHONY: check @@ -777,6 +775,7 @@ endef # Also remove the dependencies and generated source files. common-clean: common-mostlyclean -rm -f $(addprefix $(objpfx),$(generated)) $(+depfiles) + -rm -f $(addprefix $(common-objpfx),$(common-generated)) -rm -f $(common-objpfx)distinfo-$(subdir) # Produce a file `stub-$(subdir)' which contains `#define __stub_FUNCTION' |