diff options
author | Tulio Magno Quites Machado Filho <tuliom@linux.vnet.ibm.com> | 2017-11-24 18:29:21 -0200 |
---|---|---|
committer | Andreas K. Hüttel <dilfridge@gentoo.org> | 2017-11-26 16:39:12 +0100 |
commit | 70339f2e9513c7b567f347fd46afce53772b9359 (patch) | |
tree | 28524bb67e13cb05cb29cc616b59cb70467cb1a4 | |
parent | Add test for bug 21041 (diff) | |
download | glibc-70339f2e9513c7b567f347fd46afce53772b9359.tar.gz glibc-70339f2e9513c7b567f347fd46afce53772b9359.tar.bz2 glibc-70339f2e9513c7b567f347fd46afce53772b9359.zip |
powerpc: Update AT_HWCAP2 bits
Linux commit ID cba6ac4869e45cc93ac5497024d1d49576e82666 reserved a new
bit for a scenario where transactional memory is available, but the
suspended state is disabled.
* sysdeps/powerpc/bits/hwcap.h (PPC_FEATURE2_HTM_NO_SUSPEND): New
macro.
(cherry picked from commit df0c40ee3a893238ac11f4c0d876a0c3b49d198d)
Signed-off-by: Tulio Magno Quites Machado Filho <tuliom@linux.vnet.ibm.com>
-rw-r--r-- | ChangeLog | 5 | ||||
-rw-r--r-- | sysdeps/powerpc/bits/hwcap.h | 2 |
2 files changed, 7 insertions, 0 deletions
@@ -1,3 +1,8 @@ +2017-11-17 Tulio Magno Quites Machado Filho <tuliom@linux.vnet.ibm.com> + + * sysdeps/powerpc/bits/hwcap.h (PPC_FEATURE2_HTM_NO_SUSPEND): New + macro. + 2017-08-09 Andreas Schwab <schwab@suse.de> * nptl/Makefile (tests) [$(build-shared) = yes]: Add diff --git a/sysdeps/powerpc/bits/hwcap.h b/sysdeps/powerpc/bits/hwcap.h index dfc71c29bb..0668ca041e 100644 --- a/sysdeps/powerpc/bits/hwcap.h +++ b/sysdeps/powerpc/bits/hwcap.h @@ -72,3 +72,5 @@ 128-bit */ #define PPC_FEATURE2_DARN 0x00200000 /* darn instruction. */ #define PPC_FEATURE2_SCV 0x00100000 /* scv syscall. */ +#define PPC_FEATURE2_HTM_NO_SUSPEND 0x00080000 /* TM without suspended + state. */ |