diff options
author | Mike Frysinger <vapier@gentoo.org> | 2019-04-24 19:07:46 +0200 |
---|---|---|
committer | Andreas K. Hüttel <dilfridge@gentoo.org> | 2019-07-04 00:42:23 +0200 |
commit | 5946442448e2448089aa92b19b97b3c69eb52547 (patch) | |
tree | 5caf61d73b451e88dabdcbd346f39ab12d8a0480 | |
parent | malloc: Set and reset all hooks for tracing (Bug 16573) (diff) | |
download | glibc-5946442448e2448089aa92b19b97b3c69eb52547.tar.gz glibc-5946442448e2448089aa92b19b97b3c69eb52547.tar.bz2 glibc-5946442448e2448089aa92b19b97b3c69eb52547.zip |
memusagestat: use local glibc when linking [BZ #18465]
The memusagestat is the only binary that has its own link line which
causes it to be linked against the existing installed C library. It
has been this way since it was originally committed in 1999, but I
don't see any reason as to why. Since we want all the programs we
build locally to be against the new copy of glibc, change the build
to be like all other programs.
(cherry picked from commit f9b645b4b0a10c43753296ce3fa40053fa44606a)
(cherry picked from commit 42dfc13abf6fbb4c7a0215238eb636b7d374e0e0)
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r-- | ChangeLog | 7 | ||||
-rw-r--r-- | NEWS | 1 | ||||
-rw-r--r-- | malloc/Makefile | 4 |
3 files changed, 10 insertions, 2 deletions
@@ -1,3 +1,10 @@ +2019-04-24 Mike Frysinger <vapier@gentoo.org> + + [BZ #18465] + * malloc/Makefile (others): Add memusagestat. + ($(objpfx)memusagestat): Delete rule. + (LDLIBS-memusagestat): New variable. + 2019-04-09 Carlos O'Donell <carlos@redhat.com> Kwok Cheung Yeung <kcy@codesourcery.com> @@ -14,6 +14,7 @@ Major new features: The following bugs are resolved with this release: [16573] malloc: Set and reset all hooks for tracing + [18465] memusagestat: use local glibc when linking [24155] x32 memcmp can treat positive length as 0 (if sign bit in RDX is set) (CVE-2019-7309) [24164] Systemtap probes need to use "nr" constraint on 32-bit Arm [24161] __run_fork_handlers self-deadlocks in malloc/tst-mallocfork2 diff --git a/malloc/Makefile b/malloc/Makefile index ab2eed09c6..aadf602dfd 100644 --- a/malloc/Makefile +++ b/malloc/Makefile @@ -131,6 +131,7 @@ ifneq ($(cross-compiling),yes) # If the gd library is available we build the `memusagestat' program. ifneq ($(LIBGD),no) others: $(objpfx)memusage +others += memusagestat install-bin = memusagestat install-bin-script += memusage generated += memusagestat memusage @@ -154,8 +155,7 @@ cpp-srcs-left := $(memusagestat-modules) lib := memusagestat include $(patsubst %,$(..)libof-iterator.mk,$(cpp-srcs-left)) -$(objpfx)memusagestat: $(memusagestat-modules:%=$(objpfx)%.o) - $(LINK.o) -o $@ $^ $(libgd-LDFLAGS) -lgd -lpng -lz -lm +LDLIBS-memusagestat = $(libgd-LDFLAGS) -lgd -lpng -lz -lm ifeq ($(run-built-tests),yes) ifeq (yes,$(build-shared)) |