diff options
author | Florian Weimer <fweimer@redhat.com> | 2019-04-25 14:58:13 +0200 |
---|---|---|
committer | Andreas K. Hüttel <dilfridge@gentoo.org> | 2019-07-04 00:42:45 +0200 |
commit | 4753b66c8993d47a918993d62379c749a1aa28a9 (patch) | |
tree | b802d78ab21001e0b0293d9bd09a52d86b06bebf | |
parent | memusagestat: use local glibc when linking [BZ #18465] (diff) | |
download | glibc-4753b66c8993d47a918993d62379c749a1aa28a9.tar.gz glibc-4753b66c8993d47a918993d62379c749a1aa28a9.tar.bz2 glibc-4753b66c8993d47a918993d62379c749a1aa28a9.zip |
Revert "memusagestat: use local glibc when linking [BZ #18465]"
This reverts commit 42dfc13abf6fbb4c7a0215238eb636b7d374e0e0.
The position of the -Wl,-rpath-link= options on the linker command
line is not correct, so the new way of linking memusagestat does not
always work.
(cherry picked from commit 0744a268bc73e42b14b83e4cf3d083c6df6344e8)
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r-- | ChangeLog | 7 | ||||
-rw-r--r-- | NEWS | 1 | ||||
-rw-r--r-- | malloc/Makefile | 4 |
3 files changed, 2 insertions, 10 deletions
@@ -1,10 +1,3 @@ -2019-04-24 Mike Frysinger <vapier@gentoo.org> - - [BZ #18465] - * malloc/Makefile (others): Add memusagestat. - ($(objpfx)memusagestat): Delete rule. - (LDLIBS-memusagestat): New variable. - 2019-04-09 Carlos O'Donell <carlos@redhat.com> Kwok Cheung Yeung <kcy@codesourcery.com> @@ -14,7 +14,6 @@ Major new features: The following bugs are resolved with this release: [16573] malloc: Set and reset all hooks for tracing - [18465] memusagestat: use local glibc when linking [24155] x32 memcmp can treat positive length as 0 (if sign bit in RDX is set) (CVE-2019-7309) [24164] Systemtap probes need to use "nr" constraint on 32-bit Arm [24161] __run_fork_handlers self-deadlocks in malloc/tst-mallocfork2 diff --git a/malloc/Makefile b/malloc/Makefile index aadf602dfd..ab2eed09c6 100644 --- a/malloc/Makefile +++ b/malloc/Makefile @@ -131,7 +131,6 @@ ifneq ($(cross-compiling),yes) # If the gd library is available we build the `memusagestat' program. ifneq ($(LIBGD),no) others: $(objpfx)memusage -others += memusagestat install-bin = memusagestat install-bin-script += memusage generated += memusagestat memusage @@ -155,7 +154,8 @@ cpp-srcs-left := $(memusagestat-modules) lib := memusagestat include $(patsubst %,$(..)libof-iterator.mk,$(cpp-srcs-left)) -LDLIBS-memusagestat = $(libgd-LDFLAGS) -lgd -lpng -lz -lm +$(objpfx)memusagestat: $(memusagestat-modules:%=$(objpfx)%.o) + $(LINK.o) -o $@ $^ $(libgd-LDFLAGS) -lgd -lpng -lz -lm ifeq ($(run-built-tests),yes) ifeq (yes,$(build-shared)) |