aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-10-31 03:29:36 -0400
committerMike Frysinger <vapier@gentoo.org>2021-11-02 22:59:07 -0400
commit0a129eb19a773d930d60b084209570f663db2053 (patch)
treec29451f6fe7b9d2ae8ebc071b7a04fb36033973a /sim/cris/Makefile.in
parentsim: hoist mn10300 & v850 igen rules up to common builds (diff)
downloadbinutils-gdb-0a129eb19a773d930d60b084209570f663db2053.tar.gz
binutils-gdb-0a129eb19a773d930d60b084209570f663db2053.tar.bz2
binutils-gdb-0a129eb19a773d930d60b084209570f663db2053.zip
sim: hoist cgen mloop rules up to common builds
These rules don't depend on the target compiler settings, so hoist the build logic up to the common builds for better parallelization. We have to extend the genmloop.sh logic a bit to allow outputting to a subdir since it always assumed cwd was the right place. We leave the cgen maintainer rules in the subdirs for now as they aren't normally run, and they rely on cgen logic that has not yet been generalized.
Diffstat (limited to 'sim/cris/Makefile.in')
-rw-r--r--sim/cris/Makefile.in32
1 files changed, 1 insertions, 31 deletions
diff --git a/sim/cris/Makefile.in b/sim/cris/Makefile.in
index 18dd2f451b5..8e6bb2ec79b 100644
--- a/sim/cris/Makefile.in
+++ b/sim/cris/Makefile.in
@@ -66,48 +66,18 @@ CRISV10F_INCLUDE_DEPS = \
$(CGEN_MAIN_CPU_DEPS) \
cpuv10.h decodev10.h engv10.h
-# FIXME: What is mono and what does "Use of `mono' is wip" mean (other
-# than the apparent; some "mono" feature is work in progress)?
-mloopv10f.c engv10.h: stamp-v10fmloop
-stamp-v10fmloop: $(srcdir)/../common/genmloop.sh mloop.in Makefile
- $(ECHO_STAMP) mloopv10f.c engv10.h
- $(SILENCE) $(SHELL) $(srccom)/genmloop.sh -shell $(SHELL) \
- -mono -no-fast -pbb -switch semcrisv10f-switch.c \
- -cpu crisv10f -infile $(srcdir)/mloop.in
- $(SILENCE) $(SHELL) $(srcroot)/move-if-change eng.hin engv10.h
- $(SILENCE) $(SHELL) $(srcroot)/move-if-change mloop.cin mloopv10f.c
- $(SILENCE) touch $@
-
# CRISV32 objs
CRISV32F_INCLUDE_DEPS = \
$(CGEN_MAIN_CPU_DEPS) \
cpuv32.h decodev32.h engv32.h
-# FIXME: What is mono and what does "Use of `mono' is wip" mean (other
-# than the apparent; some "mono" feature is work in progress)?
-mloopv32f.c engv32.h: stamp-v32fmloop
-# We depend on stamp-v10fmloop to get serialization to avoid
-# racing with it for the same temporary file-names when "make -j".
-stamp-v32fmloop: stamp-v10fmloop $(srcdir)/../common/genmloop.sh mloop.in Makefile
- $(ECHO_STAMP) mloopv32f.c engv32.h
- $(SILENCE) $(SHELL) $(srccom)/genmloop.sh -shell $(SHELL) \
- -mono -no-fast -pbb -switch semcrisv32f-switch.c \
- -cpu crisv32f -infile $(srcdir)/mloop.in
- $(SILENCE) $(SHELL) $(srcroot)/move-if-change eng.hin engv32.h
- $(SILENCE) $(SHELL) $(srcroot)/move-if-change mloop.cin mloopv32f.c
- $(SILENCE) touch $@
-
cris-clean:
- for v in 10 32; do \
- rm -f mloopv$${v}f.c engv$${v}.h stamp-v$${v}fmloop; \
- rm -f stamp-v$${v}fcpu; \
- done
-rm -f stamp-arch
-rm -f tmp-*
# Useful when making CGEN-generated files manually, without --enable-cgen-maint.
-stamps: stamp-v10fmloop stamp-v32fmloop stamp-arch stamp-v10fcpu stamp-v32fcpu
+stamps: stamp-arch stamp-v10fcpu stamp-v32fcpu
stamp-arch: $(CGEN_READ_SCM) $(CGEN_ARCH_SCM) $(CPU_DIR)/cris.cpu Makefile
$(MAKE) cgen-arch $(CGEN_FLAGS_TO_PASS) mach=crisv10,crisv32 \