summaryrefslogtreecommitdiff
path: root/gold
diff options
context:
space:
mode:
authorCary Coutant <ccoutant@gmail.com>2016-06-29 23:24:35 -0700
committerCary Coutant <ccoutant@gmail.com>2016-06-29 23:24:35 -0700
commit6e2565079204ae2d2c0a5fa15fcd233e9c614f0b (patch)
treef16940402e3519e77603638fd29d268dfd600d42 /gold
parentUpdate "make clean" in gold/testsuite. (diff)
downloadbinutils-gdb-6e2565079204ae2d2c0a5fa15fcd233e9c614f0b.tar.gz
binutils-gdb-6e2565079204ae2d2c0a5fa15fcd233e9c614f0b.tar.bz2
binutils-gdb-6e2565079204ae2d2c0a5fa15fcd233e9c614f0b.zip
Fix gold testsuite failure with GCC 6.
With GCC 6 when not using -static-libstdc++, the operator delete(void*) function is defined in the shared C++ support library, rather than in the main program. The test script is too aggressive in checking for this symbol's presence among the exported symbols. This patch removes the check for that symbol. gold/ PR gold/20310 * testsuite/dynamic_list.sh: Remove check for _ZdlPv.
Diffstat (limited to 'gold')
-rw-r--r--gold/ChangeLog6
-rwxr-xr-xgold/testsuite/dynamic_list.sh1
2 files changed, 6 insertions, 1 deletions
diff --git a/gold/ChangeLog b/gold/ChangeLog
index 5e1fddceca5..239df36f234 100644
--- a/gold/ChangeLog
+++ b/gold/ChangeLog
@@ -1,5 +1,11 @@
2016-06-29 Cary Coutant <ccoutant@gmail.com>
+gold/
+ PR gold/20310
+ * testsuite/dynamic_list.sh: Remove check for _ZdlPv.
+
+2016-06-29 Cary Coutant <ccoutant@gmail.com>
+
* testsuite/Makefile.am (MOSTLYCLEANFILES): Add eh_test_2.
* testsuite/Makefile.in: Regenerate.
diff --git a/gold/testsuite/dynamic_list.sh b/gold/testsuite/dynamic_list.sh
index 96117604749..0dbd05a3d6f 100755
--- a/gold/testsuite/dynamic_list.sh
+++ b/gold/testsuite/dynamic_list.sh
@@ -38,7 +38,6 @@ check()
}
check dynamic_list.stdout "main" # comes via --dynamic-list
-check dynamic_list.stdout "_ZdlPv" # "operator delete(void*)"
check dynamic_list.stdout "_Z4t1_6v" # t1_6()
check dynamic_list.stdout "_ZN4t16aD1Ev" # t16a:~t16a()
check dynamic_list.stdout "_ZN4t16a1tEv" # t16a:t()