aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEgeyar Bagcioglu <egeyar.bagcioglu@oracle.com>2019-02-19 16:12:44 -0800
committerCary Coutant <ccoutant@gmail.com>2019-02-19 16:13:24 -0800
commit7ae39e2d406dbec568c5ffd462119037b994fdf9 (patch)
tree8f6e921deb682b55a758a42f3305a8cb1cc29bd3 /gold/testsuite/aarch64_pr23870_foo.c
parentAutomatic date update in version.in (diff)
downloadbinutils-gdb-7ae39e2d406dbec568c5ffd462119037b994fdf9.tar.gz
binutils-gdb-7ae39e2d406dbec568c5ffd462119037b994fdf9.tar.bz2
binutils-gdb-7ae39e2d406dbec568c5ffd462119037b994fdf9.zip
Check whether symbols with MOVW_.ABS relocations require PLT entries (aarch64).
2019-02-19 Egeyar Bagcioglu <egeyar.bagcioglu@oracle.com> gold/ PR gold/23870 * aarch64.cc (Target_aarch64::Scan::global): Check if a symbol with R_AARCH64_MOVW_.ABS_* relocations requires a PLT entry. * testsuite/Makefile.am: Add aarch64_pr23870 test case. * testsuite/Makefile.in: Regenerate. * testsuite/aarch64_pr23870_bar.c: New file. * testsuite/aarch64_pr23870_foo.c: New file. * testsuite/aarch64_pr23870_main.S: New file.
Diffstat (limited to 'gold/testsuite/aarch64_pr23870_foo.c')
-rw-r--r--gold/testsuite/aarch64_pr23870_foo.c6
1 files changed, 6 insertions, 0 deletions
diff --git a/gold/testsuite/aarch64_pr23870_foo.c b/gold/testsuite/aarch64_pr23870_foo.c
new file mode 100644
index 00000000000..ade3ee6329d
--- /dev/null
+++ b/gold/testsuite/aarch64_pr23870_foo.c
@@ -0,0 +1,6 @@
+void foo (void (*bar)(void));
+
+void foo (void (*bar)(void))
+{
+ bar();
+}