summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/files/patches/2.5-libdir.patch')
-rw-r--r--dev-lang/python/files/patches/2.5-libdir.patch126
1 files changed, 0 insertions, 126 deletions
diff --git a/dev-lang/python/files/patches/2.5-libdir.patch b/dev-lang/python/files/patches/2.5-libdir.patch
deleted file mode 100644
index 0347f41..0000000
--- a/dev-lang/python/files/patches/2.5-libdir.patch
+++ /dev/null
@@ -1,126 +0,0 @@
---- ./Lib/distutils/sysconfig.py~ 2006-06-27 11:08:25.000000000 +0100
-+++ ./Lib/distutils/sysconfig.py 2006-08-09 14:38:58.000000000 +0100
-@@ -100,7 +100,8 @@
-
- if os.name == "posix":
- libpython = os.path.join(prefix,
-- "lib", "python" + get_python_version())
-+ "@@GENTOO_LIBDIR@@",
-+ "python" + get_python_version())
- if standard_lib:
- return libpython
- else:
-@@ -409,7 +410,7 @@
- # command. (It's also needed for non-MS compilers on Windows, and
- # it's taken care of for them by the 'build_ext.get_libraries()'
- # method.)
-- g['LDSHARED'] = ("%s -L%s/lib -lpython%s" %
-+ g['LDSHARED'] = ("%s -L%s/@@GENTOO_LIBDIR@@ -lpython%s" %
- (linkerscript, PREFIX, get_python_version()))
-
- global _config_vars
---- ./Lib/distutils/command/install.py~ 2006-03-27 22:55:21.000000000 +0100
-+++ ./Lib/distutils/command/install.py 2006-08-09 14:36:01.000000000 +0100
-@@ -38,8 +38,8 @@
-
- INSTALL_SCHEMES = {
- 'unix_prefix': {
-- 'purelib': '$base/lib/python$py_version_short/site-packages',
-- 'platlib': '$platbase/lib/python$py_version_short/site-packages',
-+ 'purelib': '$base/@@GENTOO_LIBDIR@@/python$py_version_short/site-packages',
-+ 'platlib': '$platbase/@@GENTOO_LIBDIR@@/python$py_version_short/site-packages',
- 'headers': '$base/include/python$py_version_short/$dist_name',
- 'scripts': '$base/bin',
- 'data' : '$base',
---- ./Lib/site.py~ 2006-08-09 14:34:02.000000000 +0100
-+++ ./Lib/site.py 2006-08-09 14:40:31.000000000 +0100
-@@ -182,13 +182,13 @@
- sitedirs = [os.path.join(prefix, "Lib", "site-packages")]
- elif os.sep == '/':
- sitedirs = [os.path.join(prefix,
-- "lib",
-+ "@@GENTOO_LIBDIR@@",
- "python" + sys.version[:3],
- "site-packages"),
-- os.path.join(prefix, "lib", "site-python")]
-- sitedirs = [os.path.join(prefix,"lib","portage","pym")] + sitedirs
-+ os.path.join(prefix, "@@GENTOO_LIBDIR@@", "site-python")]
-+ sitedirs = [os.path.join(prefix, "@@GENTOO_LIBDIR@@", "portage","pym")] + sitedirs
- else:
-- sitedirs = [prefix, os.path.join(prefix, "lib", "site-packages")]
-+ sitedirs = [prefix, os.path.join(prefix, "@@GENTOO_LIBDIR@@", "site-packages")]
- if sys.platform == 'darwin':
- # for framework builds *only* we add the standard Apple
- # locations. Currently only per-user, but /Library and
---- ./Makefile.pre.in~ 2006-07-30 17:20:10.000000000 +0100
-+++ ./Makefile.pre.in 2006-08-09 14:46:42.000000000 +0100
-@@ -84,11 +84,11 @@
-
- # Expanded directories
- BINDIR= $(exec_prefix)/bin
--LIBDIR= $(exec_prefix)/lib
-+LIBDIR= $(exec_prefix)/@@GENTOO_LIBDIR@@
- MANDIR= @mandir@
- INCLUDEDIR= @includedir@
- CONFINCLUDEDIR= $(exec_prefix)/include
--SCRIPTDIR= $(prefix)/lib
-+SCRIPTDIR= $(prefix)/@@GENTOO_LIBDIR@@
-
- # Detailed destination directories
- BINLIBDEST= $(LIBDIR)/python$(VERSION)
---- ./setup.py~ 2006-08-09 14:45:13.000000000 +0100
-+++ ./setup.py 2006-08-09 14:46:21.000000000 +0100
-@@ -504,11 +504,11 @@
- elif self.compiler.find_library_file(lib_dirs, 'curses'):
- readline_libs.append('curses')
- elif self.compiler.find_library_file(lib_dirs +
-- ['/usr/lib/termcap'],
-+ ['/usr/@@GENTOO_LIBDIR@@/termcap'],
- 'termcap'):
- readline_libs.append('termcap')
- exts.append( Extension('readline', ['readline.c'],
-- library_dirs=['/usr/lib/termcap'],
-+ library_dirs=['/usr/@@GENTOO_LIBDIR@@/termcap'],
- extra_link_args=readline_extra_link_args,
- libraries=readline_libs) )
- if platform not in ['mac']:
---- ./Modules/Setup.dist~ 2006-08-09 14:42:29.000000000 +0100
-+++ ./Modules/Setup.dist 2006-08-09 14:42:45.000000000 +0100
-@@ -448,7 +448,7 @@
- # Andrew Kuchling's zlib module.
- # This require zlib 1.1.3 (or later).
- # See http://www.gzip.org/zlib/
--#zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz
-+zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/@@GENTOO_LIBDIR@@ -lz
-
- # Interface to the Expat XML parser
- #
---- ./Modules/getpath.c~ 2006-08-09 14:43:13.000000000 +0100
-+++ ./Modules/getpath.c 2006-08-09 14:43:43.000000000 +0100
-@@ -129,7 +129,7 @@
- static char exec_prefix[MAXPATHLEN+1];
- static char progpath[MAXPATHLEN+1];
- static char *module_search_path = NULL;
--static char lib_python[] = "lib/python" VERSION;
-+static char lib_python[] = "@@GENTOO_LIBDIR@@/python" VERSION;
-
- static void
- reduce(char *dir)
-@@ -524,7 +524,7 @@
- }
- else
- strncpy(zip_path, PREFIX, MAXPATHLEN);
-- joinpath(zip_path, "lib/python00.zip");
-+ joinpath(zip_path, "@@GENTOO_LIBDIR@@/python00.zip");
- bufsz = strlen(zip_path); /* Replace "00" with version */
- zip_path[bufsz - 6] = VERSION[0];
- zip_path[bufsz - 5] = VERSION[2];
-@@ -534,7 +534,7 @@
- fprintf(stderr,
- "Could not find platform dependent libraries <exec_prefix>\n");
- strncpy(exec_prefix, EXEC_PREFIX, MAXPATHLEN);
-- joinpath(exec_prefix, "lib/lib-dynload");
-+ joinpath(exec_prefix, "@@GENTOO_LIBDIR@@/lib-dynload");
- }
- /* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-