From 0b700ca6eab1c26071f83c5b4f75ffe4703de39e Mon Sep 17 00:00:00 2001
From: Jeroen Roovers <jer@gentoo.org>
Date: Thu, 5 Jun 2014 21:24:22 +0000
Subject: Version bump.

(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
---
 sys-boot/unetbootin/ChangeLog             |  7 ++-
 sys-boot/unetbootin/unetbootin-608.ebuild | 90 +++++++++++++++++++++++++++++++
 2 files changed, 96 insertions(+), 1 deletion(-)
 create mode 100644 sys-boot/unetbootin/unetbootin-608.ebuild

(limited to 'sys-boot')

diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index 2b73a4990878..26ee10924d0d 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for sys-boot/unetbootin
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.104 2014/04/22 15:14:55 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.105 2014/06/05 21:24:22 jer Exp $
+
+*unetbootin-608 (05 Jun 2014)
+
+  05 Jun 2014; Jeroen Roovers <jer@gentoo.org> +unetbootin-608.ebuild:
+  Version bump.
 
 *unetbootin-603 (22 Apr 2014)
 
diff --git a/sys-boot/unetbootin/unetbootin-608.ebuild b/sys-boot/unetbootin/unetbootin-608.ebuild
new file mode 100644
index 000000000000..8b6e22df2ffd
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-608.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-608.ebuild,v 1.1 2014/06/05 21:24:22 jer Exp $
+
+EAPI=5
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
+distributions."
+HOMEPAGE="http://unetbootin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+UNBI_LINGUAS="
+	am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
+	ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
+	zh_CN zh_TW
+"
+
+for lingua in ${UNBI_LINGUAS}; do
+	IUSE="${IUSE} linguas_${lingua}"
+done
+
+S="${WORKDIR}"
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND="
+	${DEPEND}
+	sys-fs/mtools
+	<sys-boot/syslinux-5
+	app-arch/p7zip
+"
+
+src_prepare() {
+	epatch "${FILESDIR}/${PN}-581-desktop.patch"
+
+	# QA check in case linguas are added or removed
+	enum() {
+		echo ${#}
+	}
+	[[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
+		|| die "Numbers of recorded and actual linguas do not match"
+	unset enum
+
+	# Make room between the last line of TRANSLATIONS and the next definition
+	sed -i \
+		-e '/^DEFINES/s|.*|\n&|g' \
+		${PN}.pro || die
+
+	# Remove localisations
+	local lingua
+	for lingua in ${UNBI_LINGUAS}; do
+		if ! use linguas_${lingua}; then
+			sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
+			rm ${PN}_${lingua}.ts || die
+		fi
+	done
+}
+
+src_configure() {
+	lupdate ${PN}.pro || die
+	lrelease ${PN}.pro || die
+	eqmake4 ${PN}.pro || die
+}
+
+src_install() {
+	dobin ${PN}
+
+	domenu ${PN}.desktop
+
+	for file in ${PN}*.png; do
+		size="${file/${PN}_}"
+		size="${size/.png}x${size/.png}"
+		insinto /usr/share/icons/hicolor/${size}/apps
+		newins ${file} ${PN}.png
+	done
+
+	local lingua
+	for lingua in ${UNBI_LINGUAS}; do
+		if use linguas_${lingua}; then
+			insinto /usr/share/${PN}
+			doins ${PN}_${lingua}.qm
+		fi
+	done
+}
-- 
cgit v1.2.3-65-gdbad