From 4572051a73087ad4ecdd4d021cc48d46cfbc795a Mon Sep 17 00:00:00 2001
From: Seemant Kulleen <seemant@gentoo.org>
Date: Mon, 10 Feb 2003 16:02:14 +0000
Subject: removed crusty ebuilds and corrected syntax error

---
 net-irc/irssi/irssi-0.8.5.ebuild    | 77 -----------------------------------
 net-irc/irssi/irssi-0.8.6-r1.ebuild | 81 -------------------------------------
 net-irc/irssi/irssi-0.8.6.ebuild    | 78 -----------------------------------
 3 files changed, 236 deletions(-)
 delete mode 100644 net-irc/irssi/irssi-0.8.5.ebuild
 delete mode 100644 net-irc/irssi/irssi-0.8.6-r1.ebuild
 delete mode 100644 net-irc/irssi/irssi-0.8.6.ebuild

(limited to 'net-irc')

diff --git a/net-irc/irssi/irssi-0.8.5.ebuild b/net-irc/irssi/irssi-0.8.5.ebuild
deleted file mode 100644
index 1efae56db624..000000000000
--- a/net-irc/irssi/irssi-0.8.5.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.5.ebuild,v 1.7 2002/10/05 05:39:22 drobbins Exp $
-
-IUSE="nls ipv6 perl"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="A modular textUI IRC client with IPv6 support."
-SRC_URI="http://irssi.org/files/${P}.tar.bz2"
-HOMEPAGE="http://irssi.org"
-
-DEPEND="virtual/glibc
-	=dev-libs/glib-1.2*
-	sys-libs/ncurses
-	perl? ( sys-devel/perl )"
-
-RDEPEND="nls? ( sys-devel/gettext )"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc"
-
-src_compile() {
-
-	# Note: there is an option to build a GUI for irssi, but according
-	# to the website the gui is no longer developed, so that option is
-	# not used here.
-	
-	# Edit these if you like
-	myconf="--without-servertest --with-bot --with-proxy --with-ncurses"
-	
-	if [ -z "`use nls`" ]
-	then
-		myconf="${myconf} --disable-nls"
-	fi
-	if [ "`use perl`" ]
-	then
-		myconf="${myconf} --enable-perl=yes"
-	fi
-	if [ "`use ipv6`" ]
-	then
-		myconf="${myconf} --enable-ipv6"
-	fi
-
-	./configure \
-		--host=${CHOST} \
-		--prefix=/usr \
-		--infodir=/usr/share/info \
-		--mandir=/usr/share/man \
-		--sysconfdir=/etc \
-		${myconf} || die "./configure failed"
-
-	emake || die
-}
-
-src_install () {
-
-	myflags=""
-	if [ "`use perl`" ]
-	then
-		R1="s/installsitearch='//"
-		R2="s/';//"
-		perl_sitearch="`perl -V:installsitearch | sed -e ${R1} -e ${R2}`"
-		myflags="${myflags} INSTALLPRIVLIB=${D}/usr"
-		myflags="${myflags} INSTALLARCHLIB=${D}/${perl_sitearch}"
-		myflags="${myflags} INSTALLSITELIB=${D}/${perl_sitearch}"
-		myflags="${myflags} INSTALLSITEARCH=${D}/${perl_sitearch}"
-	fi
-
-	make DESTDIR=${D} \
-		docdir=/usr/share/doc/${PF} \
-		gnulocaledir=${D}/usr/share/locale \
-		${myflags} \
-		install || die
-
-	dodoc AUTHORS ChangeLog README TODO NEWS
-}
diff --git a/net-irc/irssi/irssi-0.8.6-r1.ebuild b/net-irc/irssi/irssi-0.8.6-r1.ebuild
deleted file mode 100644
index 3df3e43b34c0..000000000000
--- a/net-irc/irssi/irssi-0.8.6-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.6-r1.ebuild,v 1.1 2002/12/22 18:33:04 blizzy Exp $
-
-IUSE="nls ipv6 perl"
-
-inherit perl-module
-
-S=${WORKDIR}/${P}
-DESCRIPTION="A modular textUI IRC client with IPv6 support."
-SRC_URI="http://irssi.org/files/${P}.tar.bz2"
-HOMEPAGE="http://irssi.org/"
-
-DEPEND="=dev-libs/glib-1.2*
-	sys-libs/ncurses
-	perl? ( sys-devel/perl )" 
-	#socks? ( >=net-misc/dante-1.1.13 )
-RDEPEND="nls? ( sys-devel/gettext )"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc"
-
-src_compile() {
-	# Note: there is an option to build a GUI for irssi, but according
-	# to the website the GUI is no longer developed, so that option is
-	# not used here.
-	
-	# Edit these if you like
-	myconf="--without-servertest --with-bot --with-proxy --with-ncurses"
-	
-	use nls || myconf="${myconf} --disable-nls"
-
-	#perl is auto-detected and must be explicitly disabled
-	use perl || myconf="${myconf} --with-perl=no"
-
-	#ipv6 needs to be explicitly enabled
-	use ipv6 && myconf="${myconf} --enable-ipv6"
-
-	#socks needs to be explicitly enabled
-	#use socks && myconf="${myconf} --with-socks"
-
-	#ssl is auto-detected and must be disabled explicitly
-	use ssl || myconf="${myconf} --disable-ssl"
-
-	./configure \
-		--host=${CHOST} \
-		--prefix=/usr \
-		--infodir=/usr/share/info \
-		--mandir=/usr/share/man \
-		--sysconfdir=/etc \
-		${myconf} || die "./configure failed"
-
-	emake || die
-}
-
-src_install() {
-	myflags=""
-
-	use perl && ( \
-		cd ${S}/src/perl/common
-		perl-module_src_prep
-		cd ${S}/src/perl/irc
-		perl-module_src_prep
-		cd ${S}/src/perl/textui
-		perl-module_src_prep
-		cd ${S}/src/perl/ui
-		perl-module_src_prep
-		cd ${S}
-	)
-
-	make DESTDIR=${D} \
-		PREFIX=${D}/usr \
-		docdir=/usr/share/doc/${PF} \
-		gnulocaledir=${D}/usr/share/locale \
-		${myflags} \
-		install || die
-
-	prepalldocs
-	dodoc AUTHORS ChangeLog README TODO NEWS
-}
diff --git a/net-irc/irssi/irssi-0.8.6.ebuild b/net-irc/irssi/irssi-0.8.6.ebuild
deleted file mode 100644
index cd282c2e7f5a..000000000000
--- a/net-irc/irssi/irssi-0.8.6.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.6.ebuild,v 1.3 2002/12/20 23:28:57 blizzy Exp $
-
-IUSE="nls ipv6 perl"
-
-inherit perl-module
-
-S=${WORKDIR}/${P}
-DESCRIPTION="A modular textUI IRC client with IPv6 support."
-SRC_URI="http://irssi.org/files/${P}.tar.bz2"
-HOMEPAGE="http://irssi.org/"
-
-DEPEND="=dev-libs/glib-1.2*
-	sys-libs/ncurses
-	perl? ( sys-devel/perl )" 
-	#socks? ( >=net-misc/dante-1.1.13 )
-RDEPEND="nls? ( sys-devel/gettext )"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc ~sparc"
-
-src_compile() {
-	# Note: there is an option to build a GUI for irssi, but according
-	# to the website the GUI is no longer developed, so that option is
-	# not used here.
-	
-	# Edit these if you like
-	myconf="--without-servertest --with-bot --with-proxy --with-ncurses"
-	
-	use nls || myconf="${myconf} --disable-nls"
-
-	#perl is auto-detected and must be explicitly disabled
-	use perl || myconf="${myconf} --with-perl=no"
-
-	#ipv6 needs to be explicitly enabled
-	use ipv6 && myconf="${myconf} --enable-ipv6"
-
-	#socks needs to be explicitly enabled
-	#use socks && myconf="${myconf} --with-socks"
-
-	./configure \
-		--host=${CHOST} \
-		--prefix=/usr \
-		--infodir=/usr/share/info \
-		--mandir=/usr/share/man \
-		--sysconfdir=/etc \
-		${myconf} || die "./configure failed"
-
-	emake || die
-}
-
-src_install() {
-	myflags=""
-
-	use perl && ( \
-		cd ${S}/src/perl/common
-		perl-module_src_prep
-		cd ${S}/src/perl/irc
-		perl-module_src_prep
-		cd ${S}/src/perl/textui
-		perl-module_src_prep
-		cd ${S}/src/perl/ui
-		perl-module_src_prep
-		cd ${S}
-	)
-
-	make DESTDIR=${D} \
-		PREFIX=${D}/usr \
-		docdir=/usr/share/doc/${PF} \
-		gnulocaledir=${D}/usr/share/locale \
-		${myflags} \
-		install || die
-
-	prepalldocs
-	dodoc AUTHORS ChangeLog README TODO NEWS
-}
-- 
cgit v1.2.3-65-gdbad