From 62e389189ea6410500546442a2ed7111eb8a8ac8 Mon Sep 17 00:00:00 2001
From: Hans de Graaff <graaff@gentoo.org>
Date: Mon, 31 May 2010 05:59:53 +0000
Subject: Bump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded
 dependency. (Portage version: 2.1.8.3/cvs/Linux x86_64)

---
 dev-ruby/actionpack/ChangeLog               |  8 +++++-
 dev-ruby/actionpack/actionpack-2.3.8.ebuild | 41 +++++++++++++++++++++++++++++
 2 files changed, 48 insertions(+), 1 deletion(-)
 create mode 100644 dev-ruby/actionpack/actionpack-2.3.8.ebuild

(limited to 'dev-ruby/actionpack')

diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 319c3330930e..737a9032d638 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ruby/actionpack
 # Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.153 2010/05/23 10:49:20 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.154 2010/05/31 05:59:53 graaff Exp $
+
+*actionpack-2.3.8 (31 May 2010)
+
+  31 May 2010; Hans de Graaff <graaff@gentoo.org> +actionpack-2.3.8.ebuild:
+  Bump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded
+  dependency.
 
   23 May 2010; Alex Legler <a3li@gentoo.org> actionpack-2.3.5-r1.ebuild:
   Add REE18 support
diff --git a/dev-ruby/actionpack/actionpack-2.3.8.ebuild b/dev-ruby/actionpack/actionpack-2.3.8.ebuild
new file mode 100644
index 000000000000..128d548904b3
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-2.3.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-2.3.8.ebuild,v 1.1 2010/05/31 05:59:53 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 jruby"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+	>=dev-ruby/rack-1.1.0"
+
+ruby_add_bdepend test "dev-ruby/activerecord:${SLOT} dev-ruby/actionmailer:${SLOT}"
+
+all_ruby_prepare() {
+	# Custom template not found in package
+	sed -i -e '/horo/d' Rakefile || die
+
+	# This tries to load a “vendorized” copy of activerecord that we
+	# will never have.
+	sed -i -e '/PATH_TO_AR/s:^:#:' test/active_record_unit.rb || die
+
+	# Fix the testsuite, the symlink is not present in the gem for
+	# some reason
+	ln -s ../../symlink_parent test/fixtures/layout_tests/layouts/symlinked
+}
-- 
cgit v1.2.3-65-gdbad