summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmlongrun')
-rw-r--r--x11-plugins/wmlongrun/ChangeLog8
-rw-r--r--x11-plugins/wmlongrun/Manifest2
-rw-r--r--x11-plugins/wmlongrun/files/digest-wmlongrun-0.2.01
-rw-r--r--x11-plugins/wmlongrun/metadata.xml5
-rw-r--r--x11-plugins/wmlongrun/wmlongrun-0.2.0.ebuild25
5 files changed, 41 insertions, 0 deletions
diff --git a/x11-plugins/wmlongrun/ChangeLog b/x11-plugins/wmlongrun/ChangeLog
new file mode 100644
index 000000000000..646ea6d71c5e
--- /dev/null
+++ b/x11-plugins/wmlongrun/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for x11-plugins/wmlongrun
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlongrun/ChangeLog,v 1.1 2004/07/17 14:24:57 s4t4n Exp $
+
+*wmlongrun-0.2.0 (17 Jul 2004)
+
+ 17 Jul 2004; Michele Noberasco <s4t4n@gentoo.org> wmlongrun-0.2.0.ebuild:
+ Initial import. Thanks to Ryan Finnie. Closes #52894.
diff --git a/x11-plugins/wmlongrun/Manifest b/x11-plugins/wmlongrun/Manifest
new file mode 100644
index 000000000000..1afb83768984
--- /dev/null
+++ b/x11-plugins/wmlongrun/Manifest
@@ -0,0 +1,2 @@
+MD5 bedfdb6914b6d6187fbf8ac48a1452d5 wmlongrun-0.2.0.ebuild 732
+MD5 b7c113e58dd30a7bc0d3d8a802a2ec80 files/digest-wmlongrun-0.2.0 66
diff --git a/x11-plugins/wmlongrun/files/digest-wmlongrun-0.2.0 b/x11-plugins/wmlongrun/files/digest-wmlongrun-0.2.0
new file mode 100644
index 000000000000..2a90a5871232
--- /dev/null
+++ b/x11-plugins/wmlongrun/files/digest-wmlongrun-0.2.0
@@ -0,0 +1 @@
+MD5 a6ba29b84929d71443eccdc2251496eb wmlongrun-0.2.0.tar.gz 74725
diff --git a/x11-plugins/wmlongrun/metadata.xml b/x11-plugins/wmlongrun/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmlongrun/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmlongrun/wmlongrun-0.2.0.ebuild b/x11-plugins/wmlongrun/wmlongrun-0.2.0.ebuild
new file mode 100644
index 000000000000..c5729fa7de1f
--- /dev/null
+++ b/x11-plugins/wmlongrun/wmlongrun-0.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlongrun/wmlongrun-0.2.0.ebuild,v 1.1 2004/07/17 14:24:57 s4t4n Exp $
+
+DESCRIPTION="A dockapp to monitor LongRun on a Transmeta Crusoe processor"
+HOMEPAGE="http://www.sh.rim.or.jp/~ssato/dockapp/index.shtml"
+SRC_URI="http://www.sh.rim.or.jp/~ssato/src/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND="virtual/x11"
+IUSE=""
+
+# Since this will only work with a Crusoe processor, it's safe to assume that
+# the functionality is only available on x86.
+KEYWORDS="~x86 -*"
+
+src_compile() {
+ econf || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Installation failed"
+ dodoc README AUTHORS TODO COPYING MAKEDEV-cpuid-msr
+}