summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/qtnotifydaemon')
-rw-r--r--x11-misc/qtnotifydaemon/ChangeLog9
-rw-r--r--x11-misc/qtnotifydaemon/files/qtnotifydaemon-1.0.14-build.patch32
-rw-r--r--x11-misc/qtnotifydaemon/metadata.xml3
-rw-r--r--x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild4
4 files changed, 45 insertions, 3 deletions
diff --git a/x11-misc/qtnotifydaemon/ChangeLog b/x11-misc/qtnotifydaemon/ChangeLog
index fb530ffa729b..ae11c5fb3ce4 100644
--- a/x11-misc/qtnotifydaemon/ChangeLog
+++ b/x11-misc/qtnotifydaemon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/qtnotifydaemon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/qtnotifydaemon/ChangeLog,v 1.3 2012/05/15 17:31:17 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/qtnotifydaemon/ChangeLog,v 1.4 2012/08/06 15:23:23 kensington Exp $
+
+ 06 Aug 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/qtnotifydaemon-1.0.14-build.patch, metadata.xml,
+ qtnotifydaemon-1.0.14.ebuild:
+ Add upstream metadata. Fix underlinking and build with GCC 4.7 wrt bug
+ #429654.
15 May 2012; Samuli Suominen <ssuominen@gentoo.org>
qtnotifydaemon-1.0.14.ebuild:
@@ -15,4 +21,3 @@
28 Jan 2012; Samuli Suominen <ssuominen@gentoo.org>
+qtnotifydaemon-1.0.14.ebuild:
Initial commit.
-
diff --git a/x11-misc/qtnotifydaemon/files/qtnotifydaemon-1.0.14-build.patch b/x11-misc/qtnotifydaemon/files/qtnotifydaemon-1.0.14-build.patch
new file mode 100644
index 000000000000..0aebc851c727
--- /dev/null
+++ b/x11-misc/qtnotifydaemon/files/qtnotifydaemon-1.0.14-build.patch
@@ -0,0 +1,32 @@
+Fixes build with GCC 4.7, as well as the gold linker.
+
+--- main.cpp
++++ main.cpp
+@@ -22,6 +22,7 @@
+ #include <signal.h>
+ #include <sys/stat.h>
+ #include <pwd.h>
++#include <unistd.h>
+ #include "dbus.h"
+ #include "notifywidget.h"
+ #include "notifyarea.h"
+--- notifyarea.cpp
++++ notifyarea.cpp
+@@ -22,6 +22,7 @@
+ #include <QSystemTrayIcon> //alex
+ #include <QDesktopWidget>
+ #include <fstream>
++#include <unistd.h>
+ #include "notifyarea.h"
+ #include "notifywidget.h"
+ #include "dbus.h"
+--- qtnotifydaemon.pro
++++ qtnotifydaemon.pro
+@@ -13,6 +13,7 @@
+ INCLUDEPATH += .
+ QT += dbus
+ RESOURCES += images.qrc
++LIBS += -lX11
+
+ # Input
+ SOURCES += main.cpp notifywidget.cpp dbus.cpp notifyarea.cpp message.cpp
diff --git a/x11-misc/qtnotifydaemon/metadata.xml b/x11-misc/qtnotifydaemon/metadata.xml
index c7a072401ae8..e44f13e08d2e 100644
--- a/x11-misc/qtnotifydaemon/metadata.xml
+++ b/x11-misc/qtnotifydaemon/metadata.xml
@@ -7,4 +7,7 @@
<email>ssuominen@gentoo.org</email>
<name>Samuli Suominen</name>
</maintainer>
+ <upstream>
+ <remote-id type="sourceforge">qtnotifydaemon</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild b/x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild
index 0e7c7b2dde33..32ff8dc4780e 100644
--- a/x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild
+++ b/x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild,v 1.3 2012/05/15 17:31:17 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild,v 1.4 2012/08/06 15:23:23 kensington Exp $
EAPI=4
inherit qt4-r2
@@ -24,6 +24,8 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}
+PATCHES=( "${FILESDIR}/${P}-build.patch" )
+
src_install() {
dobin ${PN}