summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/pound')
-rw-r--r--www-servers/pound/ChangeLog8
-rw-r--r--www-servers/pound/Manifest23
-rw-r--r--www-servers/pound/files/digest-pound-1.91
-rw-r--r--www-servers/pound/files/pound.init-1.923
-rw-r--r--www-servers/pound/pound-1.8.3.ebuild4
-rw-r--r--www-servers/pound/pound-1.9.ebuild50
6 files changed, 91 insertions, 18 deletions
diff --git a/www-servers/pound/ChangeLog b/www-servers/pound/ChangeLog
index 523c7c34c4be..cd967ccd7f11 100644
--- a/www-servers/pound/ChangeLog
+++ b/www-servers/pound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/pound
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.8 2005/06/28 13:47:01 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.9 2005/07/07 15:45:08 mkennedy Exp $
+
+*pound-1.9 (07 Jul 2005)
+
+ 07 Jul 2005; Matthew Kennedy <mkennedy@gentoo.org> +pound-1.9.ebuild:
+ New upstream version; Keywording ~amd64; Resolves Bug #70487; New init.d
+ file for incompatible changes beginning with 1.9.
28 Jun 2005; Aaron Walker <ka0ttic@gentoo.org> pound-1.8.3.ebuild:
Added static support via USE=static for bug 84482.
diff --git a/www-servers/pound/Manifest b/www-servers/pound/Manifest
index 7997eb5bedb5..ba7a01624fde 100644
--- a/www-servers/pound/Manifest
+++ b/www-servers/pound/Manifest
@@ -1,18 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 80c79efb58b6ace68114f624e843a564 pound-1.8.3.ebuild 1149
-MD5 05792285ec2b1c8a753313e5d1574eb4 pound-1.7.ebuild 1149
-MD5 fcfb8a9fd918193533aa6251bccf282c ChangeLog 2401
+MD5 e017d0163ef51ea917abd4f1e64c7907 ChangeLog 2628
MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
-MD5 887a882063050c34c66dcfb8091711bf files/pound.init 583
-MD5 1b3ef0c3cf70a54e0ea0c16066ea3261 files/digest-pound-1.8.3 60
+MD5 05792285ec2b1c8a753313e5d1574eb4 pound-1.7.ebuild 1149
+MD5 484a2681e42c7494a3a60443201261fa pound-1.8.3.ebuild 1156
+MD5 71e8853e316cee3ea3421aeb6d35951c pound-1.9.ebuild 1166
MD5 a5bfd8880ab9b367f5333083252548db files/digest-pound-1.7 58
+MD5 1b3ef0c3cf70a54e0ea0c16066ea3261 files/digest-pound-1.8.3 60
MD5 4c7b6277bb33061b615ac9059c74cf62 files/pound.cfg 830
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCwVUvEZCkKN40op4RAmDUAJ9kaeaOn/YlSmde9kdFTr2KMheFrACePg57
-3q6SXne63ITsJSJOMwutvJM=
-=TZom
------END PGP SIGNATURE-----
+MD5 887a882063050c34c66dcfb8091711bf files/pound.init 583
+MD5 d15f0a09b8947377df0afdedaf3a50a3 files/digest-pound-1.9 58
+MD5 0b8bb24d6fb88f692d06888928da5886 files/pound.init-1.9 603
diff --git a/www-servers/pound/files/digest-pound-1.9 b/www-servers/pound/files/digest-pound-1.9
new file mode 100644
index 000000000000..58dfb24e451b
--- /dev/null
+++ b/www-servers/pound/files/digest-pound-1.9
@@ -0,0 +1 @@
+MD5 f1ec64357e0a53ed8050847517209525 Pound-1.9.tgz 143284
diff --git a/www-servers/pound/files/pound.init-1.9 b/www-servers/pound/files/pound.init-1.9
new file mode 100644
index 000000000000..75d2aa5260ef
--- /dev/null
+++ b/www-servers/pound/files/pound.init-1.9
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/files/pound.init-1.9,v 1.1 2005/07/07 15:45:08 mkennedy Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting pound"
+ if [ ! -f "/etc/pound.cfg" ]; then
+ eend 1 "configfile /etc/pound.cfg not found."
+ fi
+ start-stop-daemon --quiet --start --exec /usr/sbin/pound -- -f /etc/pound.cfg -p /var/run/pound.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping pound"
+ start-stop-daemon --quiet --stop --pidfile /var/run/pound.pid
+ eend $?
+}
diff --git a/www-servers/pound/pound-1.8.3.ebuild b/www-servers/pound/pound-1.8.3.ebuild
index d26ba81feba0..9cafb1e135c4 100644
--- a/www-servers/pound/pound-1.8.3.ebuild
+++ b/www-servers/pound/pound-1.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-1.8.3.ebuild,v 1.4 2005/06/28 13:47:01 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-1.8.3.ebuild,v 1.5 2005/07/07 15:45:08 mkennedy Exp $
inherit flag-o-matic
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.apsis.ch/pound/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc ~sparc alpha ~mips ~hppa"
+KEYWORDS="x86 ppc ~sparc alpha ~mips ~hppa ~amd64"
IUSE="ssl msdav unsafe static"
DEPEND="virtual/libc
diff --git a/www-servers/pound/pound-1.9.ebuild b/www-servers/pound/pound-1.9.ebuild
new file mode 100644
index 000000000000..5290f914cc59
--- /dev/null
+++ b/www-servers/pound/pound-1.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-1.9.ebuild,v 1.1 2005/07/07 15:45:08 mkennedy Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/p/P}"
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+HOMEPAGE="http://www.apsis.ch/pound/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc ~sparc alpha ~mips ~hppa ~amd64"
+IUSE="ssl msdav unsafe static"
+
+DEPEND="virtual/libc
+ ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ use static && append-ldflags -static
+
+ econf \
+ $(use_with ssl) \
+ $(use_enable msdav) \
+ $(use_enable unsafe) \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ dosbin pound
+ doman pound.8
+
+ dodoc README FAQ
+
+ newinitd ${FILESDIR}/${PN}.init-${PV} ${PN}
+
+ insinto /etc
+ doins ${FILESDIR}/pound.cfg
+}
+
+pkg_postinst() {
+ einfo "No demo-/sample-configfile is included in the distribution -- read the man-page"
+ einfo "for more info."
+ einfo "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+}