summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/python-singledispatch')
-rw-r--r--virtual/python-singledispatch/ChangeLog10
-rw-r--r--virtual/python-singledispatch/Manifest2
-rw-r--r--virtual/python-singledispatch/metadata.xml17
-rw-r--r--virtual/python-singledispatch/python-singledispatch-0.ebuild18
4 files changed, 47 insertions, 0 deletions
diff --git a/virtual/python-singledispatch/ChangeLog b/virtual/python-singledispatch/ChangeLog
new file mode 100644
index 000000000000..fda33a7532fe
--- /dev/null
+++ b/virtual/python-singledispatch/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for virtual/python-singledispatch
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-singledispatch/ChangeLog,v 1.1 2014/11/15 12:35:12 idella4 Exp $
+
+*python-singledispatch-0 (15 Nov 2014)
+
+ 15 Nov 2014; Ian Delaney <idella4@gentoo.org> +metadata.xml,
+ +python-singledispatch-0.ebuild:
+ new ebuild to support dev-python/singledispatch, ebuild by proxy maintainers
+ listed in metadata, closes Bug #521928
diff --git a/virtual/python-singledispatch/Manifest b/virtual/python-singledispatch/Manifest
new file mode 100644
index 000000000000..8d8ce820f614
--- /dev/null
+++ b/virtual/python-singledispatch/Manifest
@@ -0,0 +1,2 @@
+EBUILD python-singledispatch-0.ebuild 445 SHA256 386cc8686b6cd82b6f91a074f01f1dc55ccd20f84cfdae21858879e8107d85cf SHA512 f48cc796a853927ae6b7d06e9d2b950a19f9ada1010124509a3baac6fa414754bb42eac8e45bcd43ff0b49dad2bc7bb0d3f65b7b7afe579d9ef05bd4720e19ca WHIRLPOOL e81cc42407643772fc60b97116be41fe1d09c4d9ad121957c4e53529e3da955a62ac3002a7133d7f53951ea0fa4d08d4280bf332dbd1ffeb4eaf482932751b5a
+MISC metadata.xml 549 SHA256 2329634e0a040caf0c267f5345ca93e3d65e0bb9cc799173d3aeb7776c441f1d SHA512 edf6d83c109fa678867efcb2a6b3e4d43b44b8175e2cdc748fc486a5af4adee34812aff9af5608151c8e7b3f13186885691d53f97463eea6d8e2ceb741750d00 WHIRLPOOL 0bfff178f98236895d601d74c232f2585531e24ca3a2218bf3381453d4d96d36cea00ef914788ebccf537d5b3b1363d939640cb8caa420d296724e44b798c9f4
diff --git a/virtual/python-singledispatch/metadata.xml b/virtual/python-singledispatch/metadata.xml
new file mode 100644
index 000000000000..543f848f4505
--- /dev/null
+++ b/virtual/python-singledispatch/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>timo@rothenpieler.org</email>
+ <name>Timo Rothenpieler</name>
+ <description>proxy maintainer</description>
+ </maintainer>
+ <maintainer>
+ <email>realnc@gmail.com</email>
+ <name>Nikos Chantziaras</name>
+ <description>proxy maintainer</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/virtual/python-singledispatch/python-singledispatch-0.ebuild b/virtual/python-singledispatch/python-singledispatch-0.ebuild
new file mode 100644
index 000000000000..db64a58e03b6
--- /dev/null
+++ b/virtual/python-singledispatch/python-singledispatch-0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-singledispatch/python-singledispatch-0.ebuild,v 1.1 2014/11/15 12:35:12 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+inherit python-r1
+
+DESCRIPTION="A virtual for the Python functools.singledispatch module"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="$(python_gen_cond_dep 'dev-python/singledispatch[${PYTHON_USEDEP}]' python2_7 python3_2 python3_3)"