summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/pmtools/files/pmtools-20051111-madt.patch')
-rw-r--r--sys-power/pmtools/files/pmtools-20051111-madt.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-power/pmtools/files/pmtools-20051111-madt.patch b/sys-power/pmtools/files/pmtools-20051111-madt.patch
new file mode 100644
index 000000000000..963da5210cfa
--- /dev/null
+++ b/sys-power/pmtools/files/pmtools-20051111-madt.patch
@@ -0,0 +1,24 @@
+diff -Nuar --exclude '*~' --exclude '*.orig' pmtools-20051111.orig/Makefile pmtools-20051111/Makefile
+--- pmtools-20051111.orig/Makefile 2005-11-11 09:07:04.000000000 -0800
++++ pmtools-20051111/Makefile 2006-05-29 17:12:54.153948801 -0700
+@@ -1,4 +1,4 @@
+-DIRS = acpidump
++DIRS = acpidump madt
+
+ all:
+ for i in $(DIRS); do $(MAKE) -C $$i $@; done
+diff -Nuar --exclude '*~' --exclude '*.orig' pmtools-20051111.orig/madt/Makefile pmtools-20051111/madt/Makefile
+--- pmtools-20051111.orig/madt/Makefile 2005-11-11 09:07:04.000000000 -0800
++++ pmtools-20051111/madt/Makefile 2006-05-29 17:15:41.877439276 -0700
+@@ -1,6 +1,10 @@
++all: madt
++
+ test: madt
+ ./madt < APIC
++
+ madt: madt.c acpi.h tables.c
+- cc -o madt madt.c
++ $(CC) $(CFLAGS) -o $@ madt.c
++
+ clean:
+ rm madt