summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/readline/ChangeLog8
-rw-r--r--sys-libs/readline/files/bash-3.0-etc-inputrc.patch39
-rw-r--r--sys-libs/readline/files/digest-readline-5.0-r16
-rw-r--r--sys-libs/readline/readline-5.0-r1.ebuild75
4 files changed, 127 insertions, 1 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index cf4cdafa870b..ae6b5ceb7370 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/readline
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.37 2004/09/29 04:24:32 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.38 2004/09/29 13:54:21 vapier Exp $
+
+*readline-5.0-r1 (29 Sep 2004)
+
+ 29 Sep 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/bash-3.0-etc-inputrc.patch, +readline-5.0-r1.ebuild:
+ Add more patches from upstream and add support for /etc/inputrc #38955.
29 Sep 2004; Lina Pezzella <j4rg0n@gentoo.org> readline-4.3-r6.ebuild:
Fixed collisions with history(3) on macos.
diff --git a/sys-libs/readline/files/bash-3.0-etc-inputrc.patch b/sys-libs/readline/files/bash-3.0-etc-inputrc.patch
new file mode 100644
index 000000000000..4331bd1da609
--- /dev/null
+++ b/sys-libs/readline/files/bash-3.0-etc-inputrc.patch
@@ -0,0 +1,39 @@
+--- bash-3.0/lib/readline/bind.c.agriffis 2004-03-03 22:39:32.000000000 -0500
++++ bash-3.0/lib/readline/bind.c 2004-08-02 13:53:02.365731918 -0400
+@@ -781,6 +781,7 @@
+ 1. the filename used for the previous call
+ 2. the value of the shell variable `INPUTRC'
+ 3. ~/.inputrc
++ 4. /etc/inputrc
+ If the file existed and could be opened and read, 0 is returned,
+ otherwise errno is returned. */
+ int
+@@ -789,17 +790,20 @@
+ {
+ /* Default the filename. */
+ if (filename == 0)
++ filename = last_readline_init_file;
++ if (filename == 0)
++ filename = sh_get_env_value ("INPUTRC");
++ if (filename == 0 || *filename == 0)
+ {
+- filename = last_readline_init_file;
+- if (filename == 0)
+- filename = sh_get_env_value ("INPUTRC");
+- if (filename == 0)
+- filename = DEFAULT_INPUTRC;
++ /* If there's trouble reading DEFAULT_INPUTRC then fall back to
++ * the system inputrc
++ */
++ filename = DEFAULT_INPUTRC;
++ if (_rl_read_init_file (filename, 0) == 0)
++ return 0;
++ filename = "/etc/inputrc";
+ }
+
+- if (*filename == 0)
+- filename = DEFAULT_INPUTRC;
+-
+ #if defined (__MSDOS__)
+ if (_rl_read_init_file (filename, 0) == 0)
+ return 0;
diff --git a/sys-libs/readline/files/digest-readline-5.0-r1 b/sys-libs/readline/files/digest-readline-5.0-r1
new file mode 100644
index 000000000000..c31a1344ce93
--- /dev/null
+++ b/sys-libs/readline/files/digest-readline-5.0-r1
@@ -0,0 +1,6 @@
+MD5 9a39d15f1ed592883f8c6671e8c13120 readline-5.0.tar.gz 1808946
+MD5 5b47ed61b6b8413746750127c70e843d readline50-001 1702
+MD5 9f803005e7e4c7d675146a9a805acbf1 readline50-002 1337
+MD5 05d59c91f80fa99ab177783229b0f769 readline50-003 3841
+MD5 aa1f6343e47f8e024488c63281d77809 readline50-004 2411
+MD5 1dc2654e0161f2e7b4f536b12e1d54b7 readline50-005 2216
diff --git a/sys-libs/readline/readline-5.0-r1.ebuild b/sys-libs/readline/readline-5.0-r1.ebuild
new file mode 100644
index 000000000000..a553951c068e
--- /dev/null
+++ b/sys-libs/readline/readline-5.0-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.0-r1.ebuild,v 1.1 2004/09/29 13:54:21 vapier Exp $
+
+inherit eutils gnuconfig
+
+# Official patches
+PLEVEL="x001 x002 x003 x004 x005"
+
+DESCRIPTION="Another cute console display library"
+HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+SRC_URI="mirror://gnu/readline/${P}.tar.gz
+ ${PLEVEL//x/mirror://gnu/${PN}/${PN}-${PV}-patches/${PN}${PV/\.}-}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+# We must be certain that we have a bash that is linked
+# to its internal readline, else we may get problems.
+DEPEND=">=app-shells/bash-2.05b-r2
+ >=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ for x in ${PLEVEL//x}
+ do
+ epatch ${DISTDIR}/${PN}${PV/\.}-${x}
+ done
+
+ epatch ${FILESDIR}/bash-3.0-etc-inputrc.patch
+ gnuconfig_update
+}
+
+src_compile() {
+ # the --libdir= is needed because if lib64 is a directory, it will default
+ # to using that... even if CONF_LIBDIR isnt set or we're using a version
+ # of portage without CONF_LIBDIR support.
+ econf --with-curses --libdir=/usr/$(get_libdir) || die
+ emake || die
+}
+
+src_install() {
+ # portage 2.0.50's einstall causes sandbox violations if lib64 is a
+ # directory, since readline's configure automatically sets libdir for you.
+ make DESTDIR="${D}" install || die
+ dodir /$(get_libdir)
+ mv ${D}/usr/$(get_libdir)/*.so* ${D}/$(get_libdir)
+
+ # Bug #4411
+ gen_usr_ldscript libreadline.so
+ gen_usr_ldscript libhistory.so
+
+ dodoc CHANGELOG CHANGES README USAGE NEWS
+ docinto ps
+ dodoc doc/*.ps
+ dohtml -r doc
+
+ # Backwards compatibility #29865
+ if [ -e ${ROOT}/$(get_libdir)/libreadline.so.4 ] ; then
+ cp -a ${ROOT}/$(get_libdir)/libreadline.so.4* ${D}/$(get_libdir)/
+ touch ${D}/$(get_libdir)/libreadline.so.4*
+ fi
+}
+
+pkg_postinst() {
+ if [ -e ${ROOT}/$(get_libdir)/libreadline.so.4 ] ; then
+ ewarn "Your old readline libraries have been copied over."
+ ewarn "You should run 'revdep-rebuild --soname libreadline.so.4' asap."
+ ewarn "Once you have, you can safely delete /$(get_libdir)/libreadline.so.4*"
+ fi
+}