summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_pkcs11')
-rw-r--r--sys-auth/pam_pkcs11/ChangeLog10
-rw-r--r--sys-auth/pam_pkcs11/pam_pkcs11-0.6.1.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/sys-auth/pam_pkcs11/ChangeLog b/sys-auth/pam_pkcs11/ChangeLog
index e7c3e2147404..3092e0a2417e 100644
--- a/sys-auth/pam_pkcs11/ChangeLog
+++ b/sys-auth/pam_pkcs11/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/pam_pkcs11
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_pkcs11/ChangeLog,v 1.12 2008/08/16 03:45:51 cardoe Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_pkcs11/ChangeLog,v 1.13 2009/06/12 14:57:31 arfrever Exp $
+
+*pam_pkcs11-0.6.1 (12 Jun 2009)
+
+ 12 Jun 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pam_pkcs11-0.6.1.ebuild:
+ Version bump.
16 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/sys-auth/pam_pkcs11/pam_pkcs11-0.6.1.ebuild b/sys-auth/pam_pkcs11/pam_pkcs11-0.6.1.ebuild
new file mode 100644
index 000000000000..bcf3435ebb5e
--- /dev/null
+++ b/sys-auth/pam_pkcs11/pam_pkcs11-0.6.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_pkcs11/pam_pkcs11-0.6.1.ebuild,v 1.1 2009/06/12 14:57:31 arfrever Exp $
+
+inherit multilib
+
+DESCRIPTION="PKCS11 Pam library"
+HOMEPAGE="http://www.opensc-project.org/pam_pkcs11"
+SRC_URI="http://www.opensc-project.org/files/pam_pkcs11/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="curl ldap pcsc-lite"
+
+RDEPEND="sys-libs/pam
+ dev-libs/openssl
+ curl? ( net-misc/curl )
+ ldap? ( net-nds/openldap )
+ pcsc-lite? ( sys-apps/pcsc-lite )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ $(use_with curl) \
+ $(use_with pcsc-lite pcsclite) \
+ $(use_with ldap)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodir /$(get_libdir)/security
+ dosym ../../usr/$(get_libdir)/security/pam_pkcs11.so /$(get_libdir)/security/
+
+ dodoc NEWS README
+}