summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/memtest86/ChangeLog8
-rw-r--r--sys-apps/memtest86/files/memtest86-3.5-build.patch30
-rw-r--r--sys-apps/memtest86/memtest86-3.5.ebuild6
3 files changed, 35 insertions, 9 deletions
diff --git a/sys-apps/memtest86/ChangeLog b/sys-apps/memtest86/ChangeLog
index 9c6afdba4628..45323a1a095c 100644
--- a/sys-apps/memtest86/ChangeLog
+++ b/sys-apps/memtest86/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/memtest86
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.36 2009/10/09 08:21:12 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.37 2010/03/31 19:49:32 robbat2 Exp $
+
+ 31 Mar 2010; Robin H. Johnson <robbat2@gentoo.org> memtest86-3.5.ebuild,
+ files/memtest86-3.5-build.patch:
+ Bug #312441: fix parallel make issue.
*memtest86-3.5 (09 Oct 2009)
diff --git a/sys-apps/memtest86/files/memtest86-3.5-build.patch b/sys-apps/memtest86/files/memtest86-3.5-build.patch
index ada8f4e909ac..6c47cddb180d 100644
--- a/sys-apps/memtest86/files/memtest86-3.5-build.patch
+++ b/sys-apps/memtest86/files/memtest86-3.5-build.patch
@@ -1,8 +1,11 @@
make sure all the flags in question force i386 and disable SSP
---- Makefile
-+++ Makefile
-@@ -10,6 +10,5 @@
+diff -Nuar --exclude '*.orig' memtest86-3.5.orig//Makefile memtest86-3.5//Makefile
+--- memtest86-3.5.orig//Makefile 2010-03-31 19:43:35.355817421 +0000
++++ memtest86-3.5//Makefile 2010-03-31 19:47:10.922462467 +0000
+@@ -8,10 +8,9 @@
+ #
+ FDISK=/dev/fd0
-AS=as -32
-CC=gcc
@@ -11,13 +14,30 @@ make sure all the flags in question force i386 and disable SSP
-CFLAGS= -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC $(SMP_FL)
+CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC -fno-stack-protector $(SMP_FL)
-@@ -28,3 +27,3 @@
+ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
+ config.o linuxbios.o memsize.o pci.o controller.o random.o extra.o \
+@@ -26,7 +25,7 @@
+ # symbols and then link it dynamically so I have full
+ # relocation information
memtest_shared: $(OBJS) memtest_shared.lds Makefile
- $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds \
+ $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds -m elf_i386 \
-o $@ $(OBJS) && \
-@@ -55,3 +54,3 @@
+ $(LD) -shared -Bsymbolic -T memtest_shared.lds -o $@ $(OBJS)
+
+@@ -53,7 +52,7 @@
+ $(CC) -c $(CFLAGS) -fno-strict-aliasing reloc.c
+
test.o: test.c
- $(CC) -c -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding test.c
+ $(CC) -c $(CFLAGS:-fPIC=) -o $@ $<
+ clean:
+ rm -f *.o *.s *.iso memtest.bin memtest memtest_shared memtest_shared.bin
+@@ -72,3 +71,6 @@
+ dos: all
+ cat mt86+_loader memtest.bin > memtest.exe
+
++head.o: head.s
++bootsect.o: bootsect.s
++setup.o: setup.s
diff --git a/sys-apps/memtest86/memtest86-3.5.ebuild b/sys-apps/memtest86/memtest86-3.5.ebuild
index 0890313e8446..1b3164715199 100644
--- a/sys-apps/memtest86/memtest86-3.5.ebuild
+++ b/sys-apps/memtest86/memtest86-3.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-3.5.ebuild,v 1.1 2009/10/09 08:21:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-3.5.ebuild,v 1.2 2010/03/31 19:49:32 robbat2 Exp $
inherit mount-boot eutils toolchain-funcs
@@ -28,6 +28,8 @@ src_unpack() {
fi
tc-export AS CC LD
+
+
}
src_install() {