summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/ChangeLog9
-rw-r--r--sys-apps/pciutils/files/digest-pciutils-2.2.6-r23
-rw-r--r--sys-apps/pciutils/files/digest-pciutils-2.2.7-r13
-rw-r--r--sys-apps/pciutils/pciutils-2.2.6-r2.ebuild50
-rw-r--r--sys-apps/pciutils/pciutils-2.2.7-r1.ebuild49
5 files changed, 113 insertions, 1 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index d325de974ff0..b30e99399d14 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.112 2007/11/02 21:25:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.113 2007/11/02 21:40:20 robbat2 Exp $
+
+*pciutils-2.2.7-r1 (02 Nov 2007)
+*pciutils-2.2.6-r2 (02 Nov 2007)
+
+ 02 Nov 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +pciutils-2.2.6-r2.ebuild, +pciutils-2.2.7-r1.ebuild:
+ Backport the HAL-zlib Gentoo patch from 2.2.8 to the other unstable ebuilds.
*pciutils-2.2.8 (02 Nov 2007)
diff --git a/sys-apps/pciutils/files/digest-pciutils-2.2.6-r2 b/sys-apps/pciutils/files/digest-pciutils-2.2.6-r2
new file mode 100644
index 000000000000..efee508018c5
--- /dev/null
+++ b/sys-apps/pciutils/files/digest-pciutils-2.2.6-r2
@@ -0,0 +1,3 @@
+MD5 e26593ab38ef9ae4457826be9e35aff8 pciutils-2.2.6.tar.gz 226049
+RMD160 9f184affb481e51ca59134f5fd72259cf5e16298 pciutils-2.2.6.tar.gz 226049
+SHA256 30019fa23996429d3bedaa1b30e32b9ddcd2eaa4fe39ec015d533af6afc0ee6b pciutils-2.2.6.tar.gz 226049
diff --git a/sys-apps/pciutils/files/digest-pciutils-2.2.7-r1 b/sys-apps/pciutils/files/digest-pciutils-2.2.7-r1
new file mode 100644
index 000000000000..10b9e48aa092
--- /dev/null
+++ b/sys-apps/pciutils/files/digest-pciutils-2.2.7-r1
@@ -0,0 +1,3 @@
+MD5 0fd75a5df05100f60fb3c5498d523160 pciutils-2.2.7.tar.gz 229424
+RMD160 5d334078572cde947da0a33158733c8d64cdd578 pciutils-2.2.7.tar.gz 229424
+SHA256 3c8536fd30d3288b1baffc75ae0521dfeed6eb72a27d800992d1bfabcc8b2441 pciutils-2.2.7.tar.gz 229424
diff --git a/sys-apps/pciutils/pciutils-2.2.6-r2.ebuild b/sys-apps/pciutils/pciutils-2.2.6-r2.ebuild
new file mode 100644
index 000000000000..0479180a7ef8
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-2.2.6-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.6-r2.ebuild,v 1.1 2007/11/02 21:40:20 robbat2 Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="network-cron zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.3-build.patch
+ epatch "${FILESDIR}"/pcimodules-${PN}-2.2.6.patch
+ epatch "${FILESDIR}"/${PN}-2.2.6-link.patch #160421
+ epatch "${FILESDIR}"/${PN}-2.2.4-update-pciids.patch
+ epatch "${FILESDIR}"/${PN}-2.2.7-update-pciids-both-forms.patch
+ epatch "${FILESDIR}"/${PN}-2.2.6-alloca.patch
+ sed -i "/^LIBDIR=/s:/lib:/$(get_libdir):" Makefile
+}
+
+src_compile() {
+ export ZLIB=$(use zlib && echo yes || echo no)
+ tc-export AR CC RANLIB
+ emake OPT="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install install-lib DESTDIR="${D}" || die
+
+ if use network-cron; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/pciutils.cron update-pciids \
+ || die "Failed to install update cronjob"
+ fi
+ # Install both forms until HAL has migrated
+ sharedir="${D}"/usr/share/misc
+ if use zlib; then
+ elog "Providing a backwards compatability non-compressed pci.ids"
+ gzip -d <"${sharedir}"/pci.ids.gz >"${sharedir}"/pci.ids
+ fi
+}
diff --git a/sys-apps/pciutils/pciutils-2.2.7-r1.ebuild b/sys-apps/pciutils/pciutils-2.2.7-r1.ebuild
new file mode 100644
index 000000000000..82729dc286cb
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-2.2.7-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.7-r1.ebuild,v 1.1 2007/11/02 21:40:20 robbat2 Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="network-cron zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.7-build.patch
+ epatch "${FILESDIR}"/pcimodules-${PN}-2.2.6.patch
+ epatch "${FILESDIR}"/${PN}-2.2.6-link.patch #160421
+ epatch "${FILESDIR}"/${PN}-2.2.4-update-pciids.patch
+ epatch "${FILESDIR}"/${PN}-2.2.7-update-pciids-both-forms.patch
+ sed -i "/^LIBDIR=/s:/lib:/$(get_libdir):" Makefile
+}
+
+src_compile() {
+ export ZLIB=$(use zlib && echo yes || echo no)
+ tc-export AR CC RANLIB
+ emake OPT="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install install-lib DESTDIR="${D}" || die
+
+ if use network-cron; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/pciutils.cron update-pciids \
+ || die "Failed to install update cronjob"
+ fi
+ # Install both forms until HAL has migrated
+ sharedir="${D}"/usr/share/misc
+ if use zlib; then
+ elog "Providing a backwards compatability non-compressed pci.ids"
+ gzip -d <"${sharedir}"/pci.ids.gz >"${sharedir}"/pci.ids
+ fi
+}