summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kicad/ChangeLog8
-rw-r--r--sci-electronics/kicad/files/digest-kicad-200707026
-rw-r--r--sci-electronics/kicad/files/kicad-20070702-wxGTK-2.6.patch24
-rw-r--r--sci-electronics/kicad/kicad-20070702.ebuild109
4 files changed, 146 insertions, 1 deletions
diff --git a/sci-electronics/kicad/ChangeLog b/sci-electronics/kicad/ChangeLog
index 052a6cfdb8d0..72af187735a8 100644
--- a/sci-electronics/kicad/ChangeLog
+++ b/sci-electronics/kicad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/kicad
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.25 2007/07/07 08:44:26 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.26 2007/07/11 09:21:04 calchan Exp $
+
+*kicad-20070702 (11 Jul 2007)
+
+ 11 Jul 2007; Denis Dupeyron <calchan@gentoo.org>
+ +files/kicad-20070702-wxGTK-2.6.patch, +kicad-20070702.ebuild:
+ Version bump with yet another wxGTK-2.6 fix.
07 Jul 2007; Denis Dupeyron <calchan@gentoo.org> kicad-20070115.ebuild,
kicad-20070525.ebuild:
diff --git a/sci-electronics/kicad/files/digest-kicad-20070702 b/sci-electronics/kicad/files/digest-kicad-20070702
new file mode 100644
index 000000000000..e6e8b8784d1d
--- /dev/null
+++ b/sci-electronics/kicad/files/digest-kicad-20070702
@@ -0,0 +1,6 @@
+MD5 d394986d81addf7542cb0deecf5eb0ae kicad-2007-07-02.tgz 62664384
+RMD160 7f80fc895ab8f737216d88a61100acb089869b96 kicad-2007-07-02.tgz 62664384
+SHA256 374ce89ef6b1baf29d59fabc835e90a6aa8caa9042c25c21cc0fab2011a0cef3 kicad-2007-07-02.tgz 62664384
+MD5 0e3549491b97c9412725a04dd71e1489 kicad-20070702.tar.bz2 11115678
+RMD160 af141117d233c91ae930b8839cbd3cf4a997c821 kicad-20070702.tar.bz2 11115678
+SHA256 91238183d588164397579fd3ff4b5531ffcd82d7d5fd36dd4ef5b2172aafeabc kicad-20070702.tar.bz2 11115678
diff --git a/sci-electronics/kicad/files/kicad-20070702-wxGTK-2.6.patch b/sci-electronics/kicad/files/kicad-20070702-wxGTK-2.6.patch
new file mode 100644
index 000000000000..59e3a3928e9e
--- /dev/null
+++ b/sci-electronics/kicad/files/kicad-20070702-wxGTK-2.6.patch
@@ -0,0 +1,24 @@
+diff -Ndur kicad-20070702/pcbnew/dialog_edit_module.cpp kicad-20070702-wxGTK-2.6/pcbnew/dialog_edit_module.cpp
+--- kicad-20070702/pcbnew/dialog_edit_module.cpp 2007-07-02 15:53:38.000000000 +0200
++++ kicad-20070702-wxGTK-2.6/pcbnew/dialog_edit_module.cpp 2007-07-07 11:11:53.000000000 +0200
+@@ -279,11 +279,6 @@
+ wxString attribut_list[3] = { _("Normal"), _("Normal+Insert"), _("Virtual") };
+ m_AttributsCtrl = new wxRadioBox( m_PanelProperties, -1, _("Attributs"), wxDefaultPosition,
+ wxSize(-1,-1), 3, attribut_list, 1);
+- m_AttributsCtrl->SetItemToolTip(0, _("Use this attribute for most non smd components"));
+- m_AttributsCtrl->SetItemToolTip(1,
+- _("Use this attribute for smd components.\nOnly components with this option are put in the footprint position list file"));
+- m_AttributsCtrl->SetItemToolTip(2,
+- _("Use this attribute for \"virtual\" components drawn on board (like a old ISA PC bus connector)"));
+ PropRightSizer->Add(m_AttributsCtrl, 0, wxGROW|wxALL, 5);
+
+ switch (m_CurrentModule->m_Attributs & 255)
+@@ -311,8 +306,6 @@
+ wxSize(-1,-1), 2, properties_list, 1);
+ m_AutoPlaceCtrl->SetSelection(
+ (m_CurrentModule->m_ModuleStatus & MODULE_is_LOCKED) ? 1 : 0);
+- m_AutoPlaceCtrl->SetItemToolTip(0, _("Enable hotkey move commands and Auto Placement"));
+- m_AutoPlaceCtrl->SetItemToolTip(1, _("Disable hotkey move commands and Auto Placement"));
+ PropRightSizer->Add(m_AutoPlaceCtrl, 0, wxGROW|wxALL, 5);
+
+ StaticText = new wxStaticText(m_PanelProperties, -1, _("Rot 90"));
diff --git a/sci-electronics/kicad/kicad-20070702.ebuild b/sci-electronics/kicad/kicad-20070702.ebuild
new file mode 100644
index 000000000000..a1acb1148306
--- /dev/null
+++ b/sci-electronics/kicad/kicad-20070702.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070702.ebuild,v 1.1 2007/07/11 09:21:04 calchan Exp $
+
+inherit eutils wxwidgets
+
+UPSTREAM_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+DESCRIPTION="Electronic schematic and PCB design tools."
+HOMEPAGE="http://www.lis.inpg.fr/realise_au_lis/kicad/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ !minimal? ( ftp://iut-tice.ujf-grenoble.fr/cao/${PN}-${UPSTREAM_PV}.tgz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples minimal unicode"
+
+DEPEND="=x11-libs/wxGTK-2.6*"
+
+pkg_setup() {
+ # Tell wxwidgets.eclass which version we need
+ WX_GTK_VER="2.6"
+
+ # Check for proper wxGTK USE flags.
+ if use unicode; then
+ need-wxwidgets unicode || die "You need to install wxGTK with unicode support."
+ else
+ need-wxwidgets gtk2 || die "You need to install wxGTK with gtk2 support."
+ fi
+ built_with_use "=x11-libs/wxGTK-${WX_GTK_VER}*" opengl || die "You need to install wxGTK with opengl support."
+}
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd ${S}
+
+ # Use the chosen wx-config executable
+ sed -i -e "s:wx-config:${WX_CONFIG}:" libs.* || die "sed failed"
+ sed -i -e "s:wx-config:${WX_CONFIG}:" */makefile.* || die "sed failed"
+
+ # Some patching is required for wxGTK-2.6
+ if WX_GTK_VER="2.6" ; then
+ sed -i -e "s:wxFD_OVERWRITE_PROMPT:wxOVERWRITE_PROMPT:" kicad/treeprj_frame.cpp || die "sed failed"
+ sed -i -e "s:, false ): ):" kicad/treeprj_datas.cpp || die "sed failed"
+ epatch ${FILESDIR}/${P}-wxGTK-2.6.patch || die "patch failed"
+ fi
+}
+
+src_compile() {
+ # Build the main executables
+ emake -f makefile.gtk || die "make failed (main)"
+
+ # Minizip needs to be built independently
+ cd kicad/minizip
+ emake -f makefile.unx || die "make failed (minizip)"
+}
+
+src_install() {
+ # kicad doesn't use the autotools yet
+ exeinto /usr/lib/${PN}/linux
+ doexe eeschema/eeschema || die "Installation failed"
+ doexe pcbnew/pcbnew || die "Installation failed"
+ doexe cvpcb/cvpcb || die "Installation failed"
+ doexe kicad/kicad || die "Installation failed"
+ doexe kicad/minizip/minizip || die "Installation failed"
+ doexe gerbview/gerbview || die "Installation failed"
+ exeinto /usr/lib/${PN}/linux/plugins
+ doexe eeschema/plugins/netlist_form_pads-pcb || die "Installation failed"
+ newicon kicad_icon.png kicad.png
+ make_wrapper kicad "/usr/lib/${PN}/linux/kicad"
+ make_desktop_entry kicad Kicad kicad.png Electronics
+
+ # kicad requires everything to be in the same place
+ cp -pPR library ${D}/usr/lib/${PN}
+ cp -pPR internat ${D}/usr/lib/${PN}
+ cp -pPR template ${D}/usr/lib/${PN}
+ cp -pPR help ${D}/usr/lib/${PN}
+ if ! use minimal ; then
+ cp -pPR ${WORKDIR}/kicad/library ${D}/usr/lib/${PN}
+ cp -pPR ${WORKDIR}/kicad/modules ${D}/usr/lib/${PN}
+ cp -pPR ${WORKDIR}/kicad/template ${D}/usr/lib/${PN}
+ if use doc ; then
+ cp -pPR ${WORKDIR}/kicad/help ${D}/usr/lib/${PN}
+ fi
+ if use examples ; then
+ cp -pPR ${WORKDIR}/kicad/demos ${D}/usr/lib/${PN}
+ fi
+ fi
+ dodoc author.txt copyright.txt news.txt contrib.txt version.txt
+}
+
+pkg_postinst() {
+ if use minimal ; then
+ ewarn "If the schematic and/or board editors complain about missing libraries when you open old projects,"
+ ewarn "you will have to take one or more of the following actions :"
+ ewarn "- Install the missing libraries manually."
+ ewarn "- Remove the libraries from the 'Libs and Dir' preferences."
+ ewarn "- Fix the libraries' locations in the 'Libs and Dir' preferences."
+ ewarn "- Emerge kicad without the 'minimal' USE flag."
+ else
+ elog "Please note that the PDF datasheets that can be linked to components from the default libraries"
+ elog "cannot be mirrored by Gentoo for legal reasons."
+ elog "If you want them, you need to download them yourself from :"
+ elog "${HOMEPAGE}"
+ elog "and install them manually."
+ fi
+ elog
+ elog "You may want to emerge media-gfx/wings if you want to create 3D models of components."
+}