summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/vimap')
-rw-r--r--net-mail/vimap/ChangeLog5
-rw-r--r--net-mail/vimap/vimap-2002c-r3.ebuild18
2 files changed, 8 insertions, 15 deletions
diff --git a/net-mail/vimap/ChangeLog b/net-mail/vimap/ChangeLog
index e846db9319d2..bdbff95c5094 100644
--- a/net-mail/vimap/ChangeLog
+++ b/net-mail/vimap/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/vimap
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vimap/ChangeLog,v 1.16 2005/05/10 19:51:04 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vimap/ChangeLog,v 1.17 2005/05/22 19:54:23 ferdy Exp $
+
+ 22 May 2005; Fernando J. Pereda <ferdy@gentoo.org> vimap-2002c-r3.ebuild:
+ pseudo-depend on mailbase +pam
10 May 2005; Rene Nussbaumer <killerfox@gentoo.org> vimap-2002c-r3.ebuild:
stable on hppa
diff --git a/net-mail/vimap/vimap-2002c-r3.ebuild b/net-mail/vimap/vimap-2002c-r3.ebuild
index 40de8286d0b4..f78429f1f0b7 100644
--- a/net-mail/vimap/vimap-2002c-r3.ebuild
+++ b/net-mail/vimap/vimap-2002c-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vimap/vimap-2002c-r3.ebuild,v 1.6 2005/05/10 19:51:04 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vimap/vimap-2002c-r3.ebuild,v 1.7 2005/05/22 19:54:23 ferdy Exp $
inherit eutils flag-o-matic
@@ -45,14 +45,13 @@ pkg_setup() {
fi
echo
# Warn people with pam flag deactivated.
- if ! built_with_use net-mail/mailbase pam;
- then
+ if ! built_with_use net-mail/mailbase pam ; then
echo
- ewarn "It is recommended to have the net-mail/mailbase package"
+ ewarn "It is needed to have the net-mail/mailbase package"
ewarn " built with the pam use flag activated. Please rebuild"
ewarn " net-mail/mailbase with pam activated."
echo
- epause 3
+ die "mailbase has to be built with use pam"
fi
}
src_unpack() {
@@ -153,15 +152,6 @@ src_install() {
docinto rfc
dodoc docs/rfc/*.txt
- ## pam.d files are provided by mailbase
- # unless mailbase wasn't built with pam.
- if ! built_with_use net-mail/mailbase pam;
- then
- insinto /etc/pam.d
- newins ${FILESDIR}/uw-imap.pam-system-auth imap
- newins ${FILESDIR}/uw-imap.pam-system-auth pop
- fi
-
insinto /etc/xinetd.d
newins ${FILESDIR}/uw-imap.xinetd imap
newins ${FILESDIR}/uw-ipop2.xinetd ipop2