summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/gajim')
-rw-r--r--net-im/gajim/ChangeLog8
-rw-r--r--net-im/gajim/files/0.11.3-buddylist-fix.patch16
-rw-r--r--net-im/gajim/files/0.11.3-keyTabswitch-fix.patch17
-rw-r--r--net-im/gajim/files/digest-gajim-0.11.3-r13
-rw-r--r--net-im/gajim/gajim-0.11.3-r1.ebuild108
5 files changed, 151 insertions, 1 deletions
diff --git a/net-im/gajim/ChangeLog b/net-im/gajim/ChangeLog
index 32611c11f154..f344feff9d56 100644
--- a/net-im/gajim/ChangeLog
+++ b/net-im/gajim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/gajim
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.59 2007/11/19 19:37:32 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.60 2007/11/25 13:12:37 welp Exp $
+
+*gajim-0.11.3-r1 (25 Nov 2007)
+
+ 25 Nov 2007; <welp@gentoo.org> +files/0.11.3-buddylist-fix.patch,
+ +files/0.11.3-keyTabswitch-fix.patch, +gajim-0.11.3-r1.ebuild:
+ Revbump with patches wrt bugs 200187 and 200186
19 Nov 2007; Jeroen Roovers <jer@gentoo.org> gajim-0.11.3.ebuild:
Marked ~hppa (bug #199687).
diff --git a/net-im/gajim/files/0.11.3-buddylist-fix.patch b/net-im/gajim/files/0.11.3-buddylist-fix.patch
new file mode 100644
index 000000000000..80b032106764
--- /dev/null
+++ b/net-im/gajim/files/0.11.3-buddylist-fix.patch
@@ -0,0 +1,16 @@
+Index: /branches/gajim_0.11.3-bugfixes/src/common/contacts.py
+===================================================================
+--- /branches/gajim_0.11.3-bugfixes/src/common/contacts.py (revision 8719)
++++ /branches/gajim_0.11.3-bugfixes/src/common/contacts.py (revision 9019)
+@@ -421,4 +421,11 @@
+ if jid2 > jid1:
+ return -1
++ # If all is the same, compare accounts, they can't be the same
++ account1 = data1['account']
++ account2 = data2['account']
++ if account1 > account2:
++ return 1
++ if account2 > account1:
++ return -1
+ return 0
+
diff --git a/net-im/gajim/files/0.11.3-keyTabswitch-fix.patch b/net-im/gajim/files/0.11.3-keyTabswitch-fix.patch
new file mode 100644
index 000000000000..4e94793acd12
--- /dev/null
+++ b/net-im/gajim/files/0.11.3-keyTabswitch-fix.patch
@@ -0,0 +1,17 @@
+Index: /branches/gajim_0.11.3-bugfixes/src/message_window.py
+===================================================================
+--- /branches/gajim_0.11.3-bugfixes/src/message_window.py (revision 8991)
++++ /branches/gajim_0.11.3-bugfixes/src/message_window.py (revision 9020)
+@@ -577,7 +577,10 @@
+ def _on_notebook_key_press(self, widget, event):
+ control = self.get_active_control()
+- #when we get a key press event in conversation textview,
++ # Ctrl+PageUP / DOWN has to be handled by notebook
++ if event.state & gtk.gdk.CONTROL_MASK and event.keyval in (
++ gtk.keysyms.Page_Down, gtk.keysyms.Page_Up):
++ return False
+ if isinstance(control, ChatControlBase):
+- #we forwarded it to message textview
++ # we forwarded it to message textview
+ control.msg_textview.emit('key_press_event', event)
+ control.msg_textview.grab_focus()
diff --git a/net-im/gajim/files/digest-gajim-0.11.3-r1 b/net-im/gajim/files/digest-gajim-0.11.3-r1
new file mode 100644
index 000000000000..1949d17c5f49
--- /dev/null
+++ b/net-im/gajim/files/digest-gajim-0.11.3-r1
@@ -0,0 +1,3 @@
+MD5 8aa21b889fb853dd47e9b94b77d01836 gajim-0.11.3.tar.gz 3933538
+RMD160 0cfd21e3e74d24a604fac25cffd1ce9954554dbc gajim-0.11.3.tar.gz 3933538
+SHA256 91e4f2ab0471885c9575163cc47fe664cc55863084e4ce12aef773b3de168dfa gajim-0.11.3.tar.gz 3933538
diff --git a/net-im/gajim/gajim-0.11.3-r1.ebuild b/net-im/gajim/gajim-0.11.3-r1.ebuild
new file mode 100644
index 000000000000..2d9f52527dd4
--- /dev/null
+++ b/net-im/gajim/gajim-0.11.3-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.11.3-r1.ebuild,v 1.1 2007/11/25 13:12:37 welp Exp $
+
+inherit multilib python eutils
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="http://www.gajim.org/"
+SRC_URI="http://www.gajim.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi dbus gnome idle libnotify nls spell srv trayicon X xhtml"
+
+DEPEND="|| (
+ ( <dev-lang/python-2.5 dev-python/pysqlite )
+ >=dev-lang/python-2.5
+ )
+ dev-python/pygtk
+ sys-devel/gettext
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+RDEPEND="gnome? ( dev-python/gnome-python-extras
+ dev-python/gnome-python-desktop
+ )
+ dbus? ( dev-python/dbus-python dev-libs/dbus-glib )
+ libnotify? ( x11-libs/libnotify )
+ xhtml? ( dev-python/docutils )
+ srv? ( net-dns/bind-tools )
+ idle? ( x11-libs/libXScrnSaver )
+ spell? ( app-text/gtkspell )
+ avahi? ( net-dns/avahi )
+ dev-python/pyopenssl"
+
+pkg_setup() {
+ if ! use dbus; then
+ if use libnotify; then
+ eerror "The dbus USE flag is required for libnotify support"
+ die "USE=\"dbus\" needed for libnotify support"
+ fi
+ if use avahi; then
+ eerror "The dbus USE flag is required for avahi support"
+ die "USE=\"dbus\" needed for avahi support"
+ fi
+ else
+ if has_version "<sys-apps/dbus-0.90" && ! built_with_use sys-apps/dbus python; then
+ eerror "Please rebuild dbus with USE=\"python\""
+ die "USE=\"python\" needed for dbus"
+ fi
+ fi
+
+ if use avahi; then
+ if ! built_with_use net-dns/avahi dbus gtk python; then
+ eerror "The following USE flags are required for correct avahi"
+ eerror "support: dbus gtk python"
+ die "Please rebuild avahi with these use flags enabled."
+ fi
+ fi
+
+ if has_version ">=dev-lang/python-2.5" && ! built_with_use dev-lang/python sqlite; then
+ eerror "Please rebuild python with USE=\"sqlite\""
+ die "USE=\"sqlite\" needed for python"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-buddylist-fix.patch"
+ epatch "${FILESDIR}/${PV}-keyTabswitch-fix.patch"
+}
+
+src_compile() {
+ local myconf
+
+ if ! use gnome; then
+ myconf="${myconf} $(use_enable trayicon)"
+ myconf="${myconf} $(use_enable idle)"
+ fi
+
+ econf $(use_enable nls) \
+ $(use_enable spell gtkspell) \
+ $(use_enable dbus remote) \
+ $(use_with X x) \
+ --docdir="/usr/share/doc/${PF}" \
+ --prefix="/usr" \
+ --libdir="/usr/$(get_libdir)" \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm "${D}/usr/share/doc/${PF}/README.html"
+ dohtml README.html
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/gajim/
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/gajim/
+}